Bug 525961 - Cannot specify -vga std type graphics card
Summary: Cannot specify -vga std type graphics card
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-27 20:40 UTC by Stephen Adler
Modified: 2009-10-02 13:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-02 13:38:57 UTC


Attachments (Terms of Use)

Description Stephen Adler 2009-09-27 20:40:15 UTC
Description of problem:
I cannot change the vga type to std which limits my resolution when I don't use the vnc console interface.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.


Steps to Reproduce:
1. Fire up virt-manager
2. Configure a windows guest
3. get really frustrated because there is no option to use the std vga graphics option available to qemu-kvm
  
Actual results:


Expected results:


Additional info:

I've written a script to startup the guest, it's basically a long command line... which is this...

sudo qemu-kvm -M pc -m 2048 -smp 2 -name windows -uuid 146d9904-976d-f2e4-06ed-32317af8a373 -pidfile /var/run/libvirt/qemu/windows.pid -localtime -boot c -drive file=/export/home/KVMVirtualSystems/windowscdrive,if=ide,index=0,boot=on -drive file=,if=ide,media=cdrom,index=2 -parallel none -usb -usbdevice tablet -soundhw es1370 -vga std

Comment 1 Mark McLoughlin 2009-10-02 13:38:57 UTC
In Fedora 12 we support this - you just need to do 'virsh edit $guest' and change the <video> tag to:

  <video>
    <model type='vga'/>
  </video>

I don't think we'll be backporting this support to Fedora 11, so I'm just going to close as resolved in rawhide.

If you want to try out and test the Fedora 12 virt bits on Fedora 11, you can grab them here:

  http://markmc.fedorapeople.org/virt-preview/

Thanks for the report


Note You need to log in before you can comment on or make changes to this bug.