Bug 526047 - Quota package fails to include quota_nld
Summary: Quota package fails to include quota_nld
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: quota
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 526280
TreeView+ depends on / blocked
 
Reported: 2009-09-28 13:54 UTC by Steve Whitehouse
Modified: 2010-09-15 13:01 UTC (History)
6 users (show)

Fixed In Version: quota-3.17-8.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 526280 (view as bug list)
Environment:
Last Closed: 2009-09-30 06:52:18 UTC


Attachments (Terms of Use)

Description Steve Whitehouse 2009-09-28 13:54:24 UTC
Description of problem:

The quota package doesn't include the quota_nld daemon, but for some reason it does include the man page for it. I assume that this is a case of it being accidentally forgotten, so please ensure this is included in the package.

Also it would be nice if we had an init script for it too.


Version-Release number of selected component (if applicable):

[root@chywoon quota-tools]# rpm -qi quota
Name        : quota                        Relocations: (not relocatable)
Version     : 3.17                              Vendor: Fedora Project
Release     : 4.fc11                        Build Date: Fri 13 Mar 2009 01:34:08 PM GMT
Install Date: Fri 11 Sep 2009 02:51:14 PM BST      Build Host: x86-1.fedora.phx.redhat.com
Group       : System Environment/Base       Source RPM: quota-3.17-4.fc11.src.rpm
Size        : 834912                           License: BSD and GPLv2+
Signature   : RSA/8, Fri 17 Apr 2009 12:48:03 AM BST, Key ID 1dc5c758d22e77f2


How reproducible:

Every time.

Comment 2 Ondrej Vasik 2009-09-29 06:19:06 UTC
Thanks for report, I'll change version to rawhide and fix there in next build after freeze. I do not plan to add this daemon for F-11 at the moment.

Comment 4 Ondrej Vasik 2009-09-29 12:17:08 UTC
Built for F-13 target in koji - https://koji.fedoraproject.org/koji/buildinfo?buildID=134187 ... could you please give it a try? However - no initscript for rpc.rquotad and quota_nld at the moment. Any specific wishes or just basic initscript would be enough?

Comment 5 Steve Whitehouse 2009-09-29 12:30:22 UTC
I think quota_nld should start after dbus (since I think the dbus feature is a good one). I don't think it needs to be anything but the most basic script really.

I've still to do some work on rpc.quotad since I have a set of patches here to implement the XFS style quota interface for GFS2 and once they are upstream the next job is to review the userland support and see how many of the standard tools will work with that interface.

I did look at the quota tools a few days ago and saw that there are a lot of "if it uses the XFS interface, it must be XFS" assumptions in the code so it will take me a little while to go though all that I think. That is a separate issue to this one though.

Comment 7 Steve Whitehouse 2009-09-29 12:32:58 UTC
The link in comment #4 seems to be broken atm:

An error occurred during a connection to koji.fedoraproject.org.

SSL peer was unable to negotiate an acceptable set of security parameters.

(Error code: ssl_error_handshake_failure_alert)

Comment 8 Ondrej Vasik 2009-09-29 12:38:31 UTC
Try just http://koji.fedoraproject.org/koji/buildinfo?buildID=134187 ... should work even without koji certificate...

Comment 9 Steve Whitehouse 2009-09-29 12:49:57 UTC
Ok, I've grabbed the SRPM and rebuilt in on F-11 as I don't have a rawhide box here atm. It looks good to me. Thanks for fixing that - I think it will be a useful feature :-)

Comment 10 Ondrej Vasik 2009-09-30 06:52:18 UTC
Well, I guess it's ok to close that one rawhide...

Comment 12 Petr Pisar 2010-09-15 13:01:33 UTC
/etc/init.d/quota_nld init script development is covered by bug #634169 now.


Note You need to log in before you can comment on or make changes to this bug.