Bug 52605 - system hangs, console none responsive
system hangs, console none responsive
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-26 11:00 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 13:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-26 11:00:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
system hangs, console none responsive.
found the following in /var/log/messages.

Aug 26 04:02:10 ocelot kernel: [drm:radeon_freelist_get] *ERROR* returning
NULL!
Aug 26 04:02:41 ocelot last message repeated 1172 times
Aug 26 04:03:42 ocelot last message repeated 2451 times
Aug 26 04:04:43 ocelot last message repeated 2451 times


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. this is the first time it happened. don't know how to reproduce it
2.
3.
	

Actual Results:  pushed the system reset button as system was unresponsive.

Expected Results:  unknown

Additional info:

Aug 26 03:55:31 ocelot kernel: [drm:radeon_freelist_get] *ERROR* returning
NULL!
Aug 26 03:56:02 ocelot last message repeated 1244 times
Aug 26 03:57:03 ocelot last message repeated 2475 times
Aug 26 03:58:04 ocelot last message repeated 2465 times
Aug 26 03:59:05 ocelot last message repeated 2462 times
Aug 26 04:00:06 ocelot last message repeated 2417 times
Aug 26 04:01:06 ocelot last message repeated 2450 times
Aug 26 04:02:08 ocelot last message repeated 2577 times
Aug 26 04:02:10 ocelot last message repeated 88 times
Aug 26 04:02:10 ocelot syslogd 1.4.1: restart.
Aug 26 04:02:10 ocelot kernel: [drm:radeon_freelist_get] *ERROR* returning
NULL!
Aug 26 04:02:41 ocelot last message repeated 1172 times
Aug 26 04:03:42 ocelot last message repeated 2451 times
Aug 26 04:04:43 ocelot last message repeated 2451 times
Aug 26 07:09:45 ocelot syslogd 1.4.1: restart.
Comment 1 Bill Nottingham 2001-08-26 22:09:04 EDT
Which exact kernel version?
Comment 2 Need Real Name 2001-08-26 23:40:03 EDT
Oops, gues I assumed some clairvoyance on your part.  This a roswell beta2
7.1.94 via the up2date process only.

kernel-smp-2.4.7-2
Comment 3 Need Real Name 2001-08-30 16:17:17 EDT
This happened again last night.  Interestingly, the screensaver that was running
was the same one running on the previous lockup.

Again entries from /var/log/messages


Aug 26 04:02:10 ocelot syslogd 1.4.1: restart.
Aug 26 04:02:10 ocelot kernel: [drm:radeon_freelist_get] *ERROR* returning NULL!
Aug 26 04:02:41 ocelot last message repeated 1172 times
Aug 26 04:03:42 ocelot last message repeated 2451 times
Aug 26 04:04:43 ocelot last message repeated 2451 times
Aug 26 07:09:45 ocelot syslogd 1.4.1: restart.
Comment 4 Arjan van de Ven 2001-08-30 16:25:01 EDT
radeon is one of those unfunny cases where the XFree program actually determines
the timing the radeon kernel driver uses, and the kernel returns NULL on
timeout. We've fixed quite a few things since -2, could you
try 2.4.7-2.18 from 

http://people.redhat.com/arjanv/testkernels   ?
(you also need the mkinitrd from the i386 directory)

ftp://people.redhat.com/mharris/testing/bleeding-edge/XFree86/4.1.0-0.99.2/

also has a new XFree with several Radeon fixes.
Comment 5 Alan Cox 2003-06-06 13:59:56 EDT
No further info so closing

Note You need to log in before you can comment on or make changes to this bug.