Bug 52606 - tcltk-8.3.3-64 build failure
Summary: tcltk-8.3.3-64 build failure
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 54910 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-26 15:44 UTC by Need Real Name
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 08:07:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-26 15:44:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
If tcltk package is not installed when building tcltk, the build
will fail when configuring itcl; itcl configure would need wish
and tclsh (and libtcl.so/libtk.so) which are not yet installed.

Version-Release number of selected component (if applicable):
8.3.3-64

How reproducible:
Always

Steps to Reproduce:
1. Start with a system without tcltk installed
2. Attempt to build (rpm -ba tcltk.spec)

Actual Results:  Build stops at itcl configure phase.

Expected Results:  Successful build.

Additional info:

Workaround: after failed build, copy the already-built wish and
tclsh to /usr/bin and libtcl.so and libtk.so to /usr/lib and
re-build.

Comment 1 Need Real Name 2001-09-03 09:43:02 UTC
Closed/rawhide? This would imply that the bug is fixed in the latest tcltk release available in
the rawhide -- still, I reported the bug against the latest tcltk package I've been able to locate
on ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/ .

Or is there a CVS repository with even later builds than those available by ftp?

Comment 2 Jens Petersen 2002-08-14 10:07:22 UTC
*** Bug 54910 has been marked as a duplicate of this bug. ***

Comment 3 Jens Petersen 2002-10-27 16:17:27 UTC
Thanks, this should be fixed in the next rawhide package release.

Comment 4 Jens Petersen 2002-12-10 07:42:44 UTC
tcltk-8.3.5-76 and later should be able to build without tcltk
being installed.


Note You need to log in before you can comment on or make changes to this bug.