Bug 526063 - IOException: Error opening /dev/mapper/jmicron_GRAID : No such file or directory
Summary: IOException: Error opening /dev/mapper/jmicron_GRAID : No such file...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:45c6940bbab9830ed...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-28 15:53 UTC by Bob Schultz
Modified: 2009-09-29 12:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 12:30:14 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (181.55 KB, text/plain)
2009-09-28 15:53 UTC, Bob Schultz
no flags Details

Description Bob Schultz 2009-09-28 15:53:29 UTC
The following was filed automatically by anaconda:
anaconda 12.31 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 177, in commitToDevice
    return self.__disk.commit_to_dev()
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in commitToDevice
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 221, in commitToDisk
    self.partedDisk.commitToDevice()
  File "/usr/lib/anaconda/storage/__init__.py", line 276, in doIt
    boot.disk.format.commitToDisk()
  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1195, in nextClicked
    self.anaconda.dispatch.gotoNext()
IOException: Error opening /dev/mapper/jmicron_GRAID           : No such file or directory

Comment 1 Bob Schultz 2009-09-28 15:53:34 UTC
Created attachment 362910 [details]
Attached traceback automatically from anaconda.

Comment 2 Bob Schultz 2009-09-28 16:30:04 UTC
Background: Install failed at "write to disk" after successfully setting up preformatted partitions on multibootable jmicron bios raid0. (NB: This whole process runs successfully with DEBIAN 5.0.3 64bit) Gigabyte EX58-UD4P motherboard, 6GB tri-channel ram, 2-640GB WD black drives in Raid0. Raid setup all default in bios, full drive allocation. Partitions set up with PM8.01, keeping extended partition under 500GB to eliminate known bug in that app. Disk was created as follows:

1)7MB Fat partition with PM8.01, formatted, set active.
2)400GB extended partition with PM8.01
3)200GB ntfs partition with PM8.01, formatted, 64K clusters.
4)500MB linux boot partition with PM8.01, formatted ext2.
5)100GB linux root partition with PM8.01, formatted ext3.
6)2GB linux swap partition with PM8.01
7)DOS sys c:, making DOS bootable
8)XP install to NTFS "D:" drive.

At this point, DOS and XP are bootable, all partitions read correctly.

Boot 64bit rawhide BOOT iso in "expert" mode. Install runs correctly right through the custom layout for the disk partitions. The preformatted boot, root, and swap partitions were assigned with no problem, but the process fails following the "write to disk" action. I'm aware of the difficulties encountered with bios raid setups, but as a point of information during my testing activities I found that the 64bit Debian 5.0.3 setup installed properly under the exact same conditions, including the grub loader, so it is not infeasible. I have tested md raid on this system and it works well, but does not provide the multiboot environment I need.

Comment 3 Hans de Goede 2009-09-29 12:30:14 UTC
Many thanks for your bugreport!

(I esp. like the fact you described what you did which lead to this crash, 
 knowing that you only re-used pre-existing partitions made this a lot easier
 to track down).

This should be fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=a532472d011b7d9c630d48d331132dd6e034caca

Which will be in anaconda-12.32-1, please wait for anaconda 12.32 to show up in rawhide and then test again. Note anaconda prints its version number on strartup, you can find it at tty1 once in the GUI part of the installer (tty1 ->
CTRL+ALT+F1)


p.s.

I'm closing this bug as the cause and the fix are both obvious, if I'm mistaken and 12.32 still has this issue, please re-open this!


Note You need to log in before you can comment on or make changes to this bug.