Bug 526207 - [kernel] upgrade to 2.6.31.1-54.fc12 breaks dbus and dependent services
Summary: [kernel] upgrade to 2.6.31.1-54.fc12 breaks dbus and dependent services
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 09:57 UTC by Joachim Frieben
Modified: 2009-09-30 04:41 UTC (History)
4 users (show)

Fixed In Version: kernel-2.6.31.1-56.fc12.x86_64
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 04:41:18 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2009-09-29 09:57:35 UTC
Description of problem:
Broken kernel for kernels later than 2.6.31.1-48.fc12. Issue was supposedly fixed in 2.6.31.1-54.fc12 but persists.

  * Tue Sep 29 2009 Dave Airlie <airlied@redhat.com> 2.6.31.1-54
  - Fix broken capabilties that stopped dbus working due to copy from user
    fixups.

Version-Release number of selected component (if applicable):
kernel-2.6.31.1-54.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot kernel 2.6.31.1-54.fc12.x86_64
  
Actual results:
Boot procedure fails for service "avahi" and blocks on service "hal". 

Expected results:
Kernel boots as expected.

Additional info:
Last working kernel is kernel-2.6.31.1-48.fc12.x86_64.


Note You need to log in before you can comment on or make changes to this bug.