Bug 526258 - grouplist and groupinstall conflict
Summary: grouplist and groupinstall conflict
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 14:24 UTC by Christoph Wickert
Modified: 2014-01-21 23:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 16:01:28 UTC


Attachments (Terms of Use)

Description Christoph Wickert 2009-09-29 14:24:04 UTC
Description of problem:
yum grouplist is not working reliably: It lists groups as installed although they are not completely installed.

Version-Release number of selected component (if applicable):
yum-3.2.23-3.fc11.noarch

How reproducible:
always

Steps to Reproduce:
1. yum groupinstall "XFCE Software Development"
2. yum remove exo-devel
3. yum grouplist
Loaded plugins: refresh-packagekit
Setting up Group Process
Installed Groups:
   ...
   XFCE Software Development

Expected results:
All members of the group should be installed or the group should not be listed as installed.

Additional info:
As a result of this packagekit wont let you install the group as (it assumes) it already is installed.

Comment 1 seth vidal 2009-09-29 14:40:20 UTC
I think you might be not understanding how a group is determined to be installed.


http://lists.baseurl.org/pipermail/yum-devel/2008-June/005310.html

Comment 2 James Antill 2009-09-29 16:01:28 UTC
but feel free to open a PackageKit bug, so it can install packages in a group that is installed.

Comment 3 Christoph Wickert 2009-09-29 17:07:32 UTC
(In reply to comment #1)
> I think you might be not understanding how a group is determined to be
> installed.

Indeed, I didn't know that. And I still think it's wrong because
- grouplist and groupinstall are behaving differently
- it's not logical (think of a large group with no mandatory packages. If one out of 100 packages is installed, the group is installed. This renders the group feature useless)
- it's unfunctional (see above)
- it's almost impossible to visualize this in any of the GUIs
- it's not even displayed in yum itself

(In reply to comment #2)
> but feel free to open a PackageKit bug, so it can install packages in a group
> that is installed.  

PackageKit relies on yum. How would you want PK to behave different from yum then?

Comment 4 James Antill 2009-09-29 17:46:33 UTC
> - grouplist and groupinstall are behaving differently

 No, they aren't.

> - it's almost impossible to visualize this in any of the GUIs

 No, for instance yumex shows that "Graphics" is installed on my machine and when I click on the installed Graphics  group I get a big list of packages of which only 3 are checked/installed.

> - it's not even displayed in yum itself

 yum groupinfo -v, shows the same data as yumex. So you can easily pick extra packages to install from the group.

 yum groupinstall Graphics wants to install all the rest of the default packages, and there is a yum plugin to alter which types of the groups get installed with groupinstall (so you can get all of the optional packages too, if you want).

Comment 5 Christoph Wickert 2009-09-29 18:30:26 UTC
(In reply to comment #4)
> > - grouplist and groupinstall are behaving differently
> 
>  No, they aren't.

Of course they are. grouplist shows the group as installed, so groupinstall should do nothing. If a package is shown as installed, yum install wont do anything ether. So the behavior is inconsistent.

>  No, for instance yumex shows that "Graphics" is installed on my machine and
> when I click on the installed Graphics  group I get a big list of packages of
> which only 3 are checked/installed.

It shouldn't show "Graphics" as installed, if only three packages are installed. Apart from that this only works for groups that appear on the top level. Remember, not all groups appear on the top level, at least in gnome-packagekit and kpackagekit, which are our primary package managers.

>  yum groupinfo -v, shows the same data as yumex. So you can easily pick extra
> packages to install from the group.

yum groupinfo -v doesn't work at all with the version of yum I'm talking about. 
yum grouplist -v only shows only the group-id. So how do I get this data?

Comment 6 Christoph Wickert 2009-10-01 15:54:58 UTC
(In reply to comment #4)
>  yum groupinfo -v, shows the same data as yumex.

Even after upgrading yum to 3.2.24, the command doesn't work. What are you talking about?

Comment 7 James Antill 2009-10-01 16:09:04 UTC
 It needs a group:

yum groupinfo -v Graphics

...as the error message and the man page point out.


Note You need to log in before you can comment on or make changes to this bug.