Bug 526296 - Impossible to install missing packages of a group
Summary: Impossible to install missing packages of a group
Keywords:
Status: CLOSED DUPLICATE of bug 489477
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 17:12 UTC by Christoph Wickert
Modified: 2010-03-09 14:27 UTC (History)
1 user (show)

Fixed In Version: 0.5.7-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-09 14:27:16 UTC


Attachments (Terms of Use)

Description Christoph Wickert 2009-09-29 17:12:57 UTC
Description of problem:
yum grouplist uses a very uncommon algorithm to find out if a group is installed. See http://lists.baseurl.org/pipermail/yum-devel/2008-June/005310.html for details. Because of this it is not possible to install a group in gpk-application if yum's definition of "installed" is already satisfied.

Version-Release number of selected component (if applicable):
gnome-packagekit-2.27.3-1.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. install all mandatory packages of a group
or
1. install a single optional package of a group that has no mandatory packages

Actual results:
The group will be shown as installed in gpk-application. Therefor it's not possible to install the rest of that group graphically.

Expected results:
Group should not be treated as installed until all default packages of that group are installed  -or-
gpk-app should allow to install packages in a group that is installed.

Additional info:
IMO the bug is not really in PK, but in yum. The yum devs think different and told me to file a bug against PK. See bug 526258 for details.

I can fully understand if you close this bug NOTABUG or WONTFIX, but in that case please help me to convince the yum guys that their definition of an "installed" group is wrong.

Comment 1 Christoph Wickert 2010-03-09 14:27:16 UTC
Fixed in PackageKit-0.5.7-1 (if not earlier). Thanks for taking care of this.

*** This bug has been marked as a duplicate of bug 489477 ***


Note You need to log in before you can comment on or make changes to this bug.