Bug 52630 - Kudzu fails to setup kernel module for Epson Stylus Color 680 usb printer.
Kudzu fails to setup kernel module for Epson Stylus Color 680 usb printer.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: hotplug (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 10:12 EDT by Stephen Tweedie
Modified: 2007-04-18 12:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 16:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2001-08-27 10:12:21 EDT
Description of Problem:


Version-Release number of selected component (if applicable):
Roswell2: 
kernel-2.4.7-2.5.athlon
kudzu-0.99.14-1

How Reproducible:
100%

Steps to Reproduce:
1. Boot with the usb printer already connected and switched on.

Actual Results:
USB kernel module "printer.o" is not loaded: the printer is not accessible
to lpd.

Expected Results:
USB kernel module "printer.o" should be loaded at boot time by kudzu.

Additional Information:
The kernel hotplug configuration is correct: removing and reattatching the
printer will generate a hotplug event which loads printer.o correctly, and
at that point all printing works fine.

The kudzu probing in /etc/sysconfig/hwconf for this printer looks like:

>>>>>>>>>>>>>
class: PRINTER
bus: USB
detached: 0
driver: unknown
desc: "Seiko Epson Corp. Stylus Color 760 / M800C / Photo 870 / Photo 875DC"
usbclass: 7
usbsubclass: 1
usbprotocol: 2
usbbus: 1
usblevel: 1
usbport: 0
vendorId: 04b8
deviceId: 0005
productrevision: unknown
>>>>>>>>>>>>>

The "driver: unknown" seems to be a symptom of the detection problem.  The
usb class/protocol are fine, and hotplug has no trouble classifying the
device as a usb printer based on that class info.
Comment 1 Bill Nottingham 2001-08-27 10:33:52 EDT
kudzu does not handle usb module loading. this appears to be a problem with
hotplug's cold-plugging support.
Comment 2 Trond Eivind Glomsrxd 2001-08-27 12:47:55 EDT
Please try hotplug-2001_04_24-11 - http://people.redhat.com/teg/hotplug/
Comment 3 Stephen Tweedie 2001-08-28 07:26:58 EDT
Still no luck: syslog has

Aug 28 11:55:52 spock kernel: usb.c: registered new driver usbdevfs
Aug 28 11:55:52 spock kernel: usb.c: registered new driver hub
Aug 28 11:55:52 spock kernel: usb-ohci.c: USB OHCI at membase 0xd0850000, IRQ 9
Aug 28 11:55:52 spock kernel: usb-ohci.c: usb-00:07.4, Advanced Micro Devices
[AMD] AMD-756 [Viper] USB
Aug 28 11:55:52 spock kernel: usb-ohci.c: AMD756 erratum 4 workaround
Aug 28 11:55:52 spock kernel: usb.c: new USB bus registered, assigned bus number 1
Aug 28 11:55:52 spock kernel: hub.c: USB hub found
Aug 28 11:55:52 spock kernel: hub.c: 4 ports detected
Aug 28 11:55:52 spock kernel: usb-ohci.c: v5.2:USB OHCI Host Controller Driver
Aug 28 11:55:52 spock kernel: hub.c: USB new device connect on bus1/1, assigned
device number 2
Aug 28 11:55:52 spock kernel: usb.c: USB device 2 (vend/prod 0x4b8/0x5) is not
claimed by any active driver.
Aug 28 11:55:52 spock kernel: hub.c: USB new device connect on bus1/2, assigned
device number 3
Aug 28 11:55:52 spock kernel: hub.c: USB hub found
Aug 28 11:55:52 spock kernel: hub.c: 4 ports detected
Aug 28 11:55:52 spock kernel: hub.c: USB new device connect on bus1/2/1,
assigned device number 4
Aug 28 11:55:52 spock kernel: usb.c: USB device 4 (vend/prod 0x46d/0xc207) is
not claimed by any active driver.

No attempt is made to load the printer module.
Comment 4 Trond Eivind Glomsrxd 2001-08-29 11:51:32 EDT
"driver: unknown" is just describing the symptom - it changes when a driver is
inserted and says "I can handle this devices".
Comment 5 Trond Eivind Glomsrxd 2001-08-31 11:46:59 EDT
Can you try enabling debugging in /sbin/hotplug and see if anything useful shows
 up in the logs?
Comment 6 Trond Eivind Glomsrxd 2001-09-12 10:59:07 EDT
Reported fixed in hotplug-2001_04_24-11

Note You need to log in before you can comment on or make changes to this bug.