This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526434 - Set HTTP_USER_AGENT to be able to open videos on Apple trailers website
Set HTTP_USER_AGENT to be able to open videos on Apple trailers website
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: totem (Show other bugs)
5.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
: Patch, ZStream
Depends On:
Blocks: 554476 673987
  Show dependency treegraph
 
Reported: 2009-09-30 05:02 EDT by Olivier Fourdan
Modified: 2013-09-23 07:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 07:15:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (803 bytes, patch)
2009-09-30 05:02 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2009-09-30 05:02:26 EDT
Created attachment 363154 [details]
Proposed patch

Description of problem:

Due to a recent change that occurred on Apple trailers website (http://www.apple.com/trailers/) it is not possible to play videos from that site even with the appropriate GStreamer plug-ins.

Version-Release number of selected component (if applicable):

totem-2.16.7-6.el5

How reproducible:

100% reproducible

Steps to Reproduce:
1. Open for example http://www.apple.com/trailers/paramount/upintheair/large.html with firefox under Red Hat Enterprise Linux 5
  
Actual results:

An error message stating that "text/html decoder plugin is required to play this stream"

Expected results:

Either the stream plays (if the appropriate GStreamer codecs are installed) or Totem complains that the codecs for Quicktime are missing (ie not text/html).

Additional info:

This issue has been addressed upstream by patching gstreamer-plugins-good:

    http://bugzilla.gnome.org/show_bug.cgi?id=592665

While this works in Fedora, this does not fix the issue in Red Hat Enterprise Linux 5 because the gst plug-in gstsouphttpsrc is not built nor installed on Red Hat Enterprise Linux 5.

Instead, this needs to be changed in totem-mozplugin itself on el5.
Comment 2 Bastien Nocera 2009-09-30 05:10:21 EDT
(In reply to comment #0)
<snip>
> This issue has been addressed upstream by patching gstreamer-plugins-good:
> 
>     http://bugzilla.gnome.org/show_bug.cgi?id=592665

Nope, it's been fixed in Totem itself:
https://bugzilla.gnome.org/show_bug.cgi?id=375867
Comment 4 RHEL Product and Program Management 2009-11-06 13:53:52 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 RHEL Product and Program Management 2010-08-09 14:52:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.