Bug 526454 - Seamonkey should check if its command line parameter is a local file
Summary: Seamonkey should check if its command line parameter is a local file
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: seamonkey
Version: 4.8
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 11:29 UTC by Radek Bíba
Modified: 2010-03-30 07:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 07:11:46 UTC


Attachments (Terms of Use)

Description Radek Bíba 2009-09-30 11:29:45 UTC
Description of problem:
I have a file called startHere.htm in my working directory, and I wanted to look at it in Seamonkey. So I ran:

$ seamonkey startHere.htm

and expected the browser to load this file. However, it took the parameter as an address and tried to load http://www.starthere.htm. I tried again with file://`pwd`/startHere.htm, and this worked. But that's pretty annoying.

Then I wanted to display a file called license_en.html in directory javacomm/en/sdk/. I thought - ok, maybe the slashes will make Seamonkey take the parameter as a path to a file. However, it tried to loaded http://www.javacomm.com/en/sdk/license_en.html.

Could Seamonkey check if the parameter is a local file and load it if it is? That's what Firefox, Konqueror and possibly other usual browsers do.

Version-Release number of selected component (if applicable):
seamonkey-1.0.9-48.el4_8

Comment 2 RHEL Product and Program Management 2010-02-10 06:58:13 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 RHEL Product and Program Management 2010-03-30 07:11:46 UTC
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.