Bug 526536 - setroubleshoot: SELinux is preventing /usr/bin/wine-preloader "mmap_zero" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing /usr/bin/wine-preloader "mmap_zero...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:744103349c6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 18:45 UTC by Alexey Kuznetsov
Modified: 2009-10-06 20:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 20:24:32 UTC
Type: ---


Attachments (Terms of Use)

Description Alexey Kuznetsov 2009-09-30 18:45:57 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/bin/wine-preloader "mmap_zero" access on <Unknown>.

Detailed Description:

SELinux denied access requested by wine-preloader. The current boolean settings
do not allow this access. If you have not setup wine-preloader to require this
access this may signal an intrusion attempt. If you do intend this access you
need to change the booleans on this system to allow the access.

Allowing Access:

Confined processes can be configured to run requiring different access, SELinux
provides booleans to allow you to turn on/off access as needed. The boolean
mmap_low_allowed is set incorrectly.
Boolean Description:
Allow certain domains to map low memory in the kernel


Fix Command:

# setsebool -P mmap_low_allowed 1

Additional Information:

Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Objects                None [ memprotect ]
Source                        wine-preloader
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.1.29-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-12.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_boolean
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.1-56.fc12.i686.PAE #1 SMP
                              Tue Sep 29 16:16:16 EDT 2009 i686 i686
Alert Count                   27
First Seen                    Wed 30 Sep 2009 07:12:44 AM MSD
Last Seen                     Wed 30 Sep 2009 09:58:52 PM MSD
Local ID                      1dbd526f-29d6-44e2-ad6d-10432337dee7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1254333532.127:26): avc:  denied  { mmap_zero } for  pid=2537 comm="wine-preloader" scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tclass=memprotect

node=(removed) type=SYSCALL msg=audit(1254333532.127:26): arch=40000003 syscall=90 success=no exit=-13 a0=bfe9ecb0 a1=0 a2=bfe9ecb0 a3=5a items=0 ppid=2536 pid=2537 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wine-preloader" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-12.fc12,catchall_boolean,wine-preloader,wine_t,wine_t,memprotect,mmap_zero
audit2allow suggests:

#============= wine_t ==============
allow wine_t self:memprotect mmap_zero;

Comment 1 Daniel Walsh 2009-09-30 20:24:32 UTC
The troubleshooter told you what to do.

# setsebool -P mmap_low_allowed 1

This is not a bug.


Note You need to log in before you can comment on or make changes to this bug.