Bug 526568 - AttributeError: 'NoneType' object has no attribute 'path'
Summary: AttributeError: 'NoneType' object has no attribute 'path'
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:ca904b7854c8b181c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 21:11 UTC by Bob Schultz
Modified: 2009-10-08 11:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 11:06:41 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (193.20 KB, text/plain)
2009-09-30 21:11 UTC, Bob Schultz
no flags Details

Description Bob Schultz 2009-09-30 21:11:06 UTC
The following was filed automatically by anaconda:
anaconda 12.32 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1878, in mkDevRoot
    dev = "%s/%s" % (instPath, root.path)
  File "/usr/lib/anaconda/storage/__init__.py", line 1045, in mkDevRoot
    self.fsset.mkDevRoot()
  File "/usr/lib/anaconda/upgrade.py", line 260, in upgradeMountFilesystems
    anaconda.id.storage.mkDevRoot()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1195, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'path'

Comment 1 Bob Schultz 2009-09-30 21:11:11 UTC
Created attachment 363242 [details]
Attached traceback automatically from anaconda.

Comment 2 Bob Schultz 2009-09-30 21:27:54 UTC
This is a follow-up to bug report 526063. The anaconda 12.32-1 install completed, but the reboot failed--Disk Boot Failure. Apparently grub was not installed or not installed properly. Tried a rescue boot, chroot /mnt/sysimage, could not grub-install.

Command grub yielded "Unknown partition signature".

grub-install /dev/mapper/jmicron-GRAID and
grub-install "/dev/mapper/jmicron-GRAID           "
yielded not found responses.

grub-install /dev/dm-0 yielded /dev/dm-0 does not have any corresponding bios drive.

Next tried an upgrade reinstall, with the resulting dump.

Under PM8.01, was able to make partition p1 active again, and regained DOS/XP boot.

Any help would be appreciated.

Comment 3 Bob Schultz 2009-10-04 16:22:42 UTC
Additional note: Following this failure, a clean install was attempted which failed on attempt to create linux /boot partition. Report filed #527035.

Comment 4 Hans de Goede 2009-10-08 11:06:41 UTC
I hit a lot of BIOS RAID related bugs while setting up a system with a partition
layout similar to yours using the installer to do the partitioning (there were
a few BIOS RAID specific regressions since F-11).

I've fixed all of these now, did an install with a similar disk  layout and then
upgraded it, this went without a hitch. So I think one of the fixes I've done also fixes this.

I'm going to close this as WORKSFORME for now. If you want to retest, please
do a network install using boot.iso from rawhide, together with one of the 2 following updates.img files (the one for the arch you are using):

http://people.fedoraproject.org/~jwrdegoede/raid-test-day-upd-i686.img
http://people.fedoraproject.org/~jwrdegoede/raid-test-day-upd-x86_64.img


Note You need to log in before you can comment on or make changes to this bug.