Bug 526599 - yum update breaks yum-utils
yum update breaks yum-utils
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 19:51 EDT by Michal Jaegermann
Modified: 2014-01-21 18:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 04:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-09-30 19:51:33 EDT
Description of problem:

After an update to yum-3.2.24-2.fc11.noarch at least repoclosure fails with

Traceback (most recent call last):
  File "/usr/bin/repoclosure", line 250, in <module>
    main()
  File "/usr/bin/repoclosure", line 166, in main
    my = RepoClosure(arch = opts.arch, config = opts.config, builddeps = opts.builddeps, pkgonly = opts.pkg)
  File "/usr/bin/repoclosure", line 75, in __init__
    self.doConfigSetup(fn = config,init_plugins=False)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 192, in doConfigSetup
    return self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 705, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 234, in _getConfig
    arch = self.arch.canonarch
AttributeError: 'list' object has no attribute 'canonarch'

It is true that installing yum-utils-1.1.23-1.fc11 from koji makes this error to  go away and repoclosure works again.  A catch is that this version of yum-utils is not even in updates-testing yet while yum-3.2.24 is already in updates.

Version-Release number of selected component (if applicable):
yum-utils-1.1.22-1.fc11

How reproducible:
always
Comment 1 Tim Lauridsen 2009-10-01 04:44:55 EDT
i have just pushed yum-utils-1.1.23 to updates-testing

so

yum --enablerepo=updates-testing update yum-utils

should fix it

Note You need to log in before you can comment on or make changes to this bug.