This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526734 - broken mime data
broken mime data
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-01 11:09 EDT by Ralf Corsepius
Modified: 2009-12-13 08:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-13 08:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 193325 None None None Never

  None (edit)
Description Ralf Corsepius 2009-10-01 11:09:57 EDT
Description of problem:

kdelibs's mime data is broken.

Version-Release number of selected component (if applicable):
kdelibs.i586 6:4.3.1-3.fc11

How reproducible:
Always.

Steps to Reproduce:
1. yum install kdelibs
2. /usr/bin/update-mime-database /usr/share/mime
3. yum remove kdelibs
4. /usr/bin/update-mime-database /usr/share/mime

Actual results:
with kdelibs installed, update-mime-database complains:

# /usr/bin/update-mime-database /usr/share/mime
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

After removing kdelibs, update-mime-database is silent.

Expected results:
Fedora to ship proper mime-data.
Comment 1 Rex Dieter 2009-12-12 23:40:36 EST
Looks like shared-mime-info may be a bit overly strict here, esp for those containing x-*

The others, I'll ping upstream kde about.
Comment 2 Bastien Nocera 2009-12-13 08:54:20 EST
That's not new, that same code has been there since the inception of shared-mime-info.

Note You need to log in before you can comment on or make changes to this bug.