Bug 52674 - Anaconda can't see RH CD1 in DVD-ROM drive
Anaconda can't see RH CD1 in DVD-ROM drive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 17:48 EDT by Danny Trinh
Modified: 2007-04-18 12:36 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 20:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DVD-ROM error message (29.41 KB, text/plain)
2001-09-05 18:22 EDT, Danny Trinh
no flags Details

  None (edit)
Description Danny Trinh 2001-08-27 17:48:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When I install Fairfax RC1 on PE6450 + DVD-ROM, I got this error message:
" I could not find a RedHat Linux CDROM in any of your CDROM drives..."


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.PE6450 + DVD-ROM (LG DVD-ROM DRN-8080B, ATAPI CD/DVD-ROM)
2.Install from CD
3.
	

Actual Results:  I can't install on PE6450 + DVD-ROM drive, by using CD-
ROM installation method.

Expected Results:  Must be able to install on PE6450+DVD-ROM.

Additional info:

I also try to use "linux ide=nodma" at the prompt, but I get the same 
result (doesn't work).
Comment 1 Michael Fulbright 2001-08-27 18:26:00 EDT
Were you able to boot from the disc?

Did you check the md5sum of the disc?
Comment 2 Danny Trinh 2001-08-28 09:42:39 EDT
Yes, the system boots from CDROM. I also use the same disc on the other system 
with CD-ROM drive, and the CD is working fine.
Comment 3 Brent Fox 2001-08-28 14:12:39 EDT
Have you tried making a boot floppy with the boot.img file and booting that way?
Comment 4 Danny Trinh 2001-08-29 10:31:07 EDT
I tried to use boot.img diskette, and the result is the same.
Comment 5 Danny Trinh 2001-08-29 12:45:27 EDT
I also tried on the other PE6450 with minimum configuration (3GB RAM), and I 
got the same result. However, the same DVD-ROM is working on PE2550.
Comment 6 Danny Trinh 2001-08-30 18:03:54 EDT
I tried RH7.1SBE, It works. Fairfax beta 3 --> no.
Comment 7 Jeremy Katz 2001-08-30 18:37:16 EDT
If you do a network install, does the drive work in the post-install environment?
Comment 8 Danny Trinh 2001-08-31 16:00:48 EDT
After network install, I can use DVD-ROM drive to read CD, and DVD disc.
Also, I tried to install RC2, I got no luck either.
Comment 9 Danny Trinh 2001-08-31 16:06:45 EDT
Below is a content of /proc/ide/hda/model

LG DVD-ROM DRN-8080B
Comment 10 Bill Nottingham 2001-09-04 12:28:32 EDT
Can you send us one of the drives? We don't have any of those here....
Also, try with the 'acpi' flag to the boot kernel.
Comment 11 Bill Nottingham 2001-09-04 12:45:23 EDT
('apic', not 'acpi'. Sorry about that.)
Comment 12 Danny Trinh 2001-09-05 17:59:35 EDT
Passing "apic" doesn't make a difference. Issue was tested on three PE6450 and 
was reproduced on all. 
"linux ide=nodma" is required when using a "SAMSUNG CD-ROM SN-124". 
Installation on PE6450 with "Toshiba XM-7002B" cdrom exits abnormally even 
when "ide=nodma" is passed.
Comment 13 Danny Trinh 2001-09-05 18:21:42 EDT
After install RC2 by using NFS install method. I can use DVD-ROM drive. 
However, there are a bunch of errors message. I will attach /var/log/messages 
to this bug.
Comment 14 Danny Trinh 2001-09-05 18:22:35 EDT
Created attachment 30999 [details]
DVD-ROM error message
Comment 15 Matt Wilson 2001-09-05 20:38:43 EDT
hardware/kernel problem.
Comment 16 Tesfamariam Michael 2001-09-06 10:40:58 EDT
The same issue was reported and closed against Florence, bug # 29089.
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=29089)
Comment 17 Michael K. Johnson 2001-09-06 17:11:58 EDT
The blacklist entry that fixed #29089 is now in the standard kernel and is
of course not backed out for this release; you can see it in the
ideblacklist patch.

We think that in our very latest BOOT kernels we have used a big enough
hammer to fix this problem.
Comment 18 Tesfamariam Michael 2001-09-06 20:30:50 EDT
Testing with boot.img from kernel 2.4.7-7 (from Rawhide) installed fine using 
this DVD. More testing will be done tomorrow.
Comment 19 John A. Hull 2001-09-11 18:23:56 EDT
Works with Gold.

Note You need to log in before you can comment on or make changes to this bug.