Bug 526776 - Add rtl8209 to gpxe-roms-qemu
Add rtl8209 to gpxe-roms-qemu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpxe (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-01 14:07 EDT by Mark McLoughlin
Modified: 2009-11-04 07:01 EST (History)
11 users (show)

See Also:
Fixed In Version: 0.9.7-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 07:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-10-01 14:07:19 EDT
The 'ne' PXE ROM isn't the correct one for qemu's ne2k_pci NIC. We need an update for F-11, F-12 and F-13 which adds rtl8029 to gpxe-roms-qemu

Should be as simple as:

-%define qemuroms ne e1000-0x100e pcnet32 rtl8139 virtio-net
+# ne is only for backwards compat with older versions of qemu
+%define qemuroms rtl8029 ne e1000-0x100e pcnet32 rtl8139 virtio-net

See below for more info:

+++ This bug was initially created as a clone of Bug #526243 +++

Created an attachment (id=363003)
screenshot of guest trying to boot via PXE

Description of problem:
If using the ne2k_pci NIC model on the guest, PXE booting doesn't work with the packaged etherboot ROM image.


Version-Release number of selected component (if applicable):
etherboot-zroms-kvm-5.4.4-16.fc11.noarch
qemu-system-x86-0.10.6-5.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
[root@mf11 ~]# cat /tmp/pxe
<domain type='qemu'>
  <name>pxe</name>
  <uuid>6812c719-61ac-4ede-dd3d-de9ff3b1a568</uuid>
  <memory>512000</memory>
  <currentMemory>512000</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='pc'>hvm</type>
    <boot dev='network'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
    <interface type='bridge'>
      <mac address='54:52:00:29:2c:5b'/>
      <source bridge='breth0'/>
      <model type='ne2k_pci'/>
    </interface>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' listen='0.0.0.0'/>
  </devices>
</domain>

[root@mf11 ~]# virsh define /tmp/pxe
Domain pxe defined from /tmp/pxe

[root@mf11 ~]# virsh start pxe
Domain pxe started


  
Actual results:
The etherboot ROM doesn't find the expected NIC. See screenshot.


Expected results:
PXE booting works.


Additional info:
The pxe-ne2k_pci ROM image for Qemu must point to rtl8029.zrom, not ne.zrom. ne.zrom is for ISA NICs.

--- Additional comment from ehabkost@redhat.com on 2009-09-29 09:06:35 EDT ---

I noticed this on Fedora 11, but it seems to be present on Fedora 12 and Rawhide, unless the gPXE ne.rom image works for ne2k_pci (which I doubt). From Rawhide qemu.spec:

pxe_link() {
  ln -s ../gpxe/$2.rom %{buildroot}%{_datadir}/%{name}/pxe-$1.bin
}
[...]
pxe_link ne2k_pci ne
[...]
Comment 1 Glauber Costa 2009-10-02 10:07:57 EDT
Do we need this for etherboot too? It is still the default for F11
Comment 2 Mark McLoughlin 2009-10-02 10:21:25 EDT
See bug #526781 for etherboot
Comment 3 Matt Domsch 2009-10-05 23:32:52 EDT
Built for rawhide, F-11, and F-12.  Will need to either break freeze for F-12 for this, or push it as an update to F-12.  How critical is this?
Comment 4 Justin M. Forbes 2009-10-05 23:46:44 EDT
This is an F-12 virt blocker, we should go ahead and request it be tagged for F-12.  If it makes the beta, great, if not it will push shortly after.
Comment 5 Fedora Update System 2009-10-05 23:57:29 EDT
gpxe-0.9.7-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gpxe-0.9.7-6.fc11
Comment 6 Mark McLoughlin 2009-10-06 11:08:31 EDT
so, this is fixed in f12; setting version to f11 since we're pushing an f11 update
Comment 7 Mark McLoughlin 2009-10-06 11:09:11 EDT
no longer blocks bug #526777
Comment 8 Fedora Update System 2009-10-06 23:11:23 EDT
gpxe-0.9.7-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpxe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10300
Comment 9 Fedora Update System 2009-11-04 07:01:51 EST
gpxe-0.9.7-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.