Bug 526895 - LVMError: vgcreate failed for VolGroup00 with two identical disks
Summary: LVMError: vgcreate failed for VolGroup00 with two identical disks
Keywords:
Status: CLOSED DUPLICATE of bug 527711
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:724847206e5a346da...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-02 12:26 UTC by Jan Stodola
Modified: 2010-01-04 11:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-04 11:13:07 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (141.73 KB, text/plain)
2009-10-02 12:26 UTC, Jan Stodola
no flags Details

Description Jan Stodola 2009-10-02 12:26:11 UTC
The following was filed automatically by anaconda:
anaconda 12.32 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 246, in vgcreate
    raise LVMError("vgcreate failed for %s" % vg_name)
  File "/usr/lib/anaconda/storage/devices.py", line 1720, in create
    lvm.vgcreate(self.name, pv_list, self.peSize)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 204, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 707, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 265, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1195, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: vgcreate failed for VolGroup00

Comment 1 Jan Stodola 2009-10-02 12:26:16 UTC
Created attachment 363470 [details]
Attached traceback automatically from anaconda.

Comment 2 Jan Stodola 2009-10-02 12:45:48 UTC
Steps to reproduce:
download boot.iso from rawhide-20091001, (anaconda-12.32)

1. # dd if=/dev/zero of=images/2GB_a.img bs=2M count=1000
2. # qemu-kvm -cdrom boot.iso -hda images/2GB_a.img -m 512 -net nic,model=virtio -net user -boot d
3. re-initialize drive when asked
4. select "Replace existing Linux system"
5. click Next, confirm writing to disk
6. select network interface, click OK
7. on the package screen select Back and Exit installer
8. exit qemu

10. # cp images/2GB_a.img images/2GB_b.img
11. # qemu-kvm -cdrom boot.iso -hda images/2GB_a.img -m 512 -net nic,model=virtio -net user -hdb images/2GB_b.img -boot d
12. when asked to Ignore/Re-initialize drive, select Ignore
13. select "Create custom layout"
14. create new VG using only one of the PVs found, create new LV, mount point /, fs ext4
15. create second VG on the second PV, create new LV, format as swap.
16. create /boot partition on existing sda1, fs ext4
17. click next, confirm formatting and writing changes to disk
18. see error with traceback

Comment 4 Bug Zapper 2009-11-16 13:11:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Hans de Goede 2010-01-04 11:13:07 UTC

*** This bug has been marked as a duplicate of bug 527711 ***


Note You need to log in before you can comment on or make changes to this bug.