Bug 526918 - update to ibus breaks eee pc suspend
update to ibus breaks eee pc suspend
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-02 09:59 EDT by Jón Fairbairn
Modified: 2009-10-13 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 11:38:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2009-10-02 09:59:28 EDT
Description of problem:
After recent upgrade to ibus, eee pc won't come back from suspend.

Version-Release number of selected component (if applicable):
ibus-1.2.0.20090927-1.fc11.i586
ibus-libs-1.2.0.20090927-1.fc11.i586
ibus-gtk-1.2.0.20090927-1.fc11.i586
ibus-rawcode-1.2.0.20090703-1.fc11.i586
ibus-m17n-1.2.0.20090617-2.fc11.i586
ibus-hangul-1.2.0.20090617-2.fc11.i586
ibus-pinyin-1.2.0.20090915-1.fc11.noarch
ibus-anthy-1.2.0.20090917-1.fc11.i586
ibus-chewing-1.2.0.20090917-2.fc11.i586


How reproducible: 

After updating to above versions every suspend I tried
failed to resume.

Steps to Reproduce:
1. upgrade ibus-*
2. suspend machine from "battery/mains" icon
3. press shift
  
Actual results:

Fan whirrs briefly then stops and power light goes from
flasing to continuous, but screen remains blank and there is
no disc access. Power button doesn't turn machine off, 
hard reset required.

Expected results:

Fan whirrs briefly and then continues to whirr at a lower
level for a while, disc access happens and the desktop
reappears.

Additional info:

Downgrading to these versions:

ibus-libs-1.1.0.20090423-1.fc11.i586
ibus-1.1.0.20090423-1.fc11.i586
ibus-rawcode-1.0.0.20090303-2.fc11.i586
ibus-gtk-1.1.0.20090423-1.fc11.i586
ibus-chewing-1.0.10.20090523-2.fc11.i586
ibus-m17n-1.1.0.20090211-4.fc11.i586
ibus-anthy-1.1.0.20090402-1.fc11.i586
ibus-pinyin-1.1.0.20090303-1.fc11.noarch
ibus-hangul-1.1.0.20090328-2.fc11.i586

resolved the problem.

I haven't repeated the upgrade/downgrade cycle because it
takes quite a while and the downgraded version works (which
is what I like, really), so I can't say that I've tested
this extensively.
Comment 1 Peng Huang 2009-10-08 22:49:18 EDT
Are you sure it is because of ibus? Which input methods are enabled? Could you try to disable ibus in im-chooser and test it again?
Comment 2 Jón Fairbairn 2009-10-13 11:38:29 EDT
> Are you sure it is because of ibus?

No, but that was the only thing that had been updated.

> Which input methods are enabled?

None were.

But having re-upgraded I cannot reproduce the issue. It looks like a transient state problem, quite with what I cannot say.

Note You need to log in before you can comment on or make changes to this bug.