Bug 527022 - Reproducible suspend misleading behavior on Acer 2920 laptop and a workaround
Summary: Reproducible suspend misleading behavior on Acer 2920 laptop and a workaround
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-03 10:34 UTC by Alex
Modified: 2010-06-28 14:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:53:52 UTC
Type: ---


Attachments (Terms of Use)

Description Alex 2009-10-03 10:34:10 UTC
Description of problem:

It is a common problem with suspend/resume but I presume I have got some statistics and some clue it is a combination of hardware/kernel conflicts.
I have an Acer Aspire 2920 laptop, 4GB RAM, 965gm chipset, BIOS v1.14, etc (the rest is not relevant, I guess).
When I make a suspend from the GNOME environment by any means (pm-suspend, choosing from menu, closing the lid, leaving for a while with the battery only) it does suspend normally and blinks with the red led around the power button.

Now, when I resume, the laptop does start BUT it comes to a working state ONLY if I press either 'spacebar' or 'power' button. In this case it is a fully working device, having all the desktop, wireless and sound back.

However, ANY other key ('enter', 'ctrl', 'f?', 'esc', 'any letter', etc) produces the following behavior (step by step):
1. blue light comes instead of red on the led around the power button.
2. Sound of the hard drive appears and a sound of the DVD-ROM appears.
3. Then silence and everything turns off including the blue led
4. After 2-3 seconds it starts up again automatically.
5. Blue led appears, sound of the DVD-ROM and maybe HDD appears, nothing else.
6. Then everything stops and only the blue led remains on.
7. No reaction to anything on keyboard, black screen, nothing ...
Only hard reset (power button pressed for 2 seconds) works. After this I start the laptop again. It starts without filesystem problems.
What is important, the file /var/log/pm-suspend.log in this bad scenario stops at the string
---------------------
...
... Performing suspend
---------------------
That's it! There is NO even the usual string
---------------------
... Awake
---------------------
No kernel-oops report is generated (it is enabled, of course).

Version-Release number of selected component (if applicable):

I have kernel 2.6.30.8-64.fc11.x86_64

How reproducible:

So far any time I have either

1. I press 'specebar' or 'power' to resume and the system resumes fine

or

2. I press ANYTHING else and have the described above mess.

Steps to Reproduce:
1. suspend by any means
2. resume by pressing NOT 'spacebar' nor 'power'
  
Actual results:

Mess as described. Unusable device.

Expected results:

Normal resume

Additional info:
Resume works fine on the same machine running WinXP SP3 32 bit. Any key on the keyboard can wake-up the machine normally. Touchpad does not work for wakeup neither in WinXP, nor in Linux. All the tests were performed MANY times (dozens, more than 30) in different desktop configuration and the statistics is good. Most of the tests were performed with AC power (had no time to work out the battery statistics).
Hibernate with AC power worked few times fine (no problem statistics).
Tried once to press 'ctrl+alt+f2' to go to the shell prompt and suspend after logging there as root. In that case the resume started normally, the screen restored to the shell, then it switched to the GNOME login prompt and the system stopped again. BUT is had the GNOME login prompt on the screen. Again only the hard reset worked and again no kernel-oops.

Comment 1 Bug Zapper 2010-04-28 10:40:32 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Bug Zapper 2010-06-28 14:53:52 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.