Bug 527093 - Cannot create a project in eclipse-3.5.0-2.fc12
Cannot create a project in eclipse-3.5.0-2.fc12
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-04 07:35 EDT by ned123
Modified: 2009-10-27 12:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 12:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 285975 None None None Never

  None (edit)
Description ned123 2009-10-04 07:35:36 EDT
Description of problem:
cannot create a new project

Version-Release number of selected component (if applicable):
eclipse-3.5.0-2.fc12

How reproducible:
every time

Steps to Reproduce:
1. start new project wizard
2. type name of the project
3. cannot do anything more, but closing window with a upper right cross
  
Actual results:
cannot make a project

Expected results:
working eclipse

Additional info:
no logs in a system log monitor
Comment 1 Andy Lawrence 2009-10-04 20:16:49 EDT
Same problem here using the same version on F12.  It appears clicking the buttons does nothing.  However tabbing to the button I want to use then using the Enter key seems to be a work-a-round.

It appears the buttons are unresponsive.  Opening via console shows no output during a mouse click.
Comment 2 Andrew Overholt 2009-10-05 08:59:48 EDT
It could be this upstream bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=285975
Comment 3 Michal Nowak 2009-10-14 09:14:07 EDT
FYI: There's workaround -- set GDK_NATIVE_WINDOWS=1 in the environment. I tested it.

What you think of having this as a default somewhere in Eclipse internals as a workaround? w/o this is Eclipse hardly usable.
Comment 4 Alexander Kurtakov 2009-10-14 09:28:25 EDT
(In reply to comment #3)
> FYI: There's workaround -- set GDK_NATIVE_WINDOWS=1 in the environment. I
> tested it.
> 
> What you think of having this as a default somewhere in Eclipse internals as a
> workaround? w/o this is Eclipse hardly usable.  

Can you test whether http://koji.fedoraproject.org/koji/buildinfo?buildID=136538 fixes the problem? 
It contains the patch from https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307
Comment 5 Michal Nowak 2009-10-14 10:09:27 EDT
Yes. That fixed that. Thanks!
Comment 6 ned123 2009-10-14 13:00:54 EDT
Solved.
eclipse-3.5.1-1.fc12 works for me.

Note You need to log in before you can comment on or make changes to this bug.