Bug 527148 - [patch] update to nltk 0.9.9
Summary: [patch] update to nltk 0.9.9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-nltk
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robin Lee
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 566204 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-05 00:42 UTC by Will Woods
Modified: 2010-05-27 18:30 UTC (History)
3 users (show)

Fixed In Version: python-nltk-0.9.9-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 18:30:41 UTC


Attachments (Terms of Use)
python-nltk.spec (3.44 KB, text/plain)
2009-10-05 00:42 UTC, Will Woods
no flags Details
use-sys-yaml patch (398 bytes, patch)
2009-10-05 00:43 UTC, Will Woods
no flags Details | Diff
nltk-0.9.9-avoid-gtk-runtime-error.patch (834 bytes, patch)
2009-10-05 00:44 UTC, Will Woods
no flags Details | Diff
Patch to the spec file to update nltk to 2.0b8 (3.04 KB, patch)
2010-05-10 08:39 UTC, Robin Lee
no flags Details | Diff

Description Will Woods 2009-10-05 00:42:52 UTC
Created attachment 363625 [details]
python-nltk.spec

python-nltk in Fedora is 0.9.2, released in March 2008; current (non-beta) nltk is 0.9.9, released May 2009.

I'm attaching the updated spec file and will attach updated patches momentarily.

Comment 1 Will Woods 2009-10-05 00:43:24 UTC
Created attachment 363626 [details]
use-sys-yaml patch

Comment 2 Will Woods 2009-10-05 00:44:09 UTC
Created attachment 363627 [details]
nltk-0.9.9-avoid-gtk-runtime-error.patch

Patch to avoid a RuntimeError when importing gtk (via nltk.app) during build

Comment 3 Michel Alexandre Salim 2009-10-05 02:01:52 UTC
Thanks, I'll look over them and forward any relevant patch upstream.

Comment 4 Michel Alexandre Salim 2009-10-05 03:06:11 UTC
Regarding those permission fixes -- since many more of them cropped up, I took a look and noticed that most of them are not even supposed to be scripts in the first place.

E-mailed upstream about it:
http://code.google.com/p/nltk/issues/detail?id=462

Since we don't really need to issue an update soon (this is not important enough to break freeze, and we can't issue an F-11 update without updating F-12 too), I'll wait for a response from upstream before deciding what to do with the permissions, and issue a Rawhide build then.

Comment 5 Will Woods 2009-10-05 12:57:54 UTC
Sure, that's reasonable. 

Note that the 'import gtk' RuntimeError fix is due to a Fedora-specific patch in pygtk2 - see http://cvs.fedoraproject.org/viewvc/devel/pygtk2/pygtk-nodisplay-exception.patch?view=markup - so upstream may be justified in rejecting that patch. 

The Proper Fix, I suppose, would be to avoid importing gtk while running setup.py. Maybe something like:

1) split the metadata in the main nltk namespace (__version__, __url__, etc) into a nltk.metadata module
2) have nltk/__init__.py do "from metadata import *" or similar, to keep them in the main namespace
3) make setup.py do "import nltk.metadata" instead

(GTG had a similar problem - see https://bugs.launchpad.net/gtg/+bug/401254)

Thanks for the quick response.

Comment 6 Bug Zapper 2009-11-16 13:16:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Robin Lee 2010-05-10 08:21:06 UTC
*** Bug 566204 has been marked as a duplicate of this bug. ***

Comment 8 Robin Lee 2010-05-10 08:39:10 UTC
Created attachment 412755 [details]
Patch to the spec file to update nltk to 2.0b8

This package seems out-dated for two years.

Can I help maintaining it? My FAS account is 'cheeselee'.

And I will also help updating it to 2.0 in Rawhide.

Comment 9 Robin Lee 2010-05-10 13:53:09 UTC
The shebangs in files in 0.9.9 should be simply removed, since all of them have been removed in upstream development branch.

Comment 10 Robin Lee 2010-05-17 04:38:23 UTC
Hope for a response.

Comment 11 Robin Lee 2010-05-17 12:52:06 UTC
(In reply to comment #2)
> Created an attachment (id=363627) [details]
> nltk-0.9.9-avoid-gtk-runtime-error.patch
> 
> Patch to avoid a RuntimeError when importing gtk (via nltk.app) during build    

Can you explain what this patch is for? It seems that nltk doesn't use gtk at all.

Comment 12 Fedora Update System 2010-05-17 13:46:09 UTC
python-nltk-0.9.9-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-nltk-0.9.9-1.fc12

Comment 13 Robin Lee 2010-05-18 16:39:36 UTC
(In reply to comment #11)
> (In reply to comment #2)
> > Created an attachment (id=363627) [details] [details]
> > nltk-0.9.9-avoid-gtk-runtime-error.patch
> > 
> > Patch to avoid a RuntimeError when importing gtk (via nltk.app) during build    
> 
> Can you explain what this patch is for? It seems that nltk doesn't use gtk at
> all.    

I found the answer when I was importing nltk in a pure console environment.

Comment 14 Fedora Update System 2010-05-18 17:39:31 UTC
python-nltk-0.9.9-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-nltk-0.9.9-2.fc12

Comment 15 Fedora Update System 2010-05-19 19:17:29 UTC
python-nltk-0.9.9-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-nltk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-nltk-0.9.9-2.fc12

Comment 16 Fedora Update System 2010-05-27 18:30:31 UTC
python-nltk-0.9.9-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.