Bug 52722 - Configuration and RPM problems
Summary: Configuration and RPM problems
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: sms_client   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 14:10 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-03 15:54:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-28 14:10:53 UTC
Hello,

I downloaded and rebuild sms_client-2.0.8y-7.src.rpm. Now I want to use it
and I have two problems:
- As a normal user, I cannot send a message. The computer says:
[ted@lorient scripts]$ sms_client xxxxxx 'test'
ERROR: Opening logfile: /var/log/smslog

I suppose it is a problem with the rights of the file smslog
-rw-r--r--    1 root     root          280 Aug 28 15:50 smslog

- As root, I cannot send a SMS either:
[root@lorient log]#  sms_client xxxxxx 'test'
ERROR: Parsing file '/etc/sms/services/minicall'
ERROR: Unrecoverable Failure Parsing file '/etc/sms/services/minicall'
ERROR: Driver Initialization Failed
Total Elapsed Time: 0 Seconds

There is no /etc/sms/services/minicall but there is a
/var/spool/sms/services/minicall (empty directory BTW).
I think there is a configuration problem somewhere but I did not find where
the location of the directory minicall was specified


Best regards


Daniel

Comment 1 Ngo Than 2001-10-16 23:22:02 UTC
sms_client is gone in 7.2, so i close it.

Comment 2 Need Real Name 2001-10-17 06:26:22 UTC
But 7.2 is not out yet and I am using 7.1
I would have appreciated some help

Daniel

Comment 3 David Keegel 2001-11-03 02:30:49 UTC
I have done a previous sms_client installation from tar file,
and may be able to help.  I'm trying to install the rpm too.

/etc/sms/services should be a directory not a file.
This looks like a bug in the RH packaging (tar -> rpm).
The /etc/sms/services file should really be /etc/sms/services/vstream.
The issues for normal users are standard for sms_client.
You get problems like cant open log file, lock file, modem device.
On my system I get around this by making the sms_client binary
set-gid uucp, and make /var/log/smslog writable by group uucp.

Comment 4 David Keegel 2001-11-03 02:35:14 UTC
I have done a previous sms_client installation from tar file,
and may be able to help.  I'm trying to install the rpm too.

/etc/sms/services should be a directory not a file.
This looks like a bug in the RH packaging (tar -> rpm).
The /etc/sms/services file should really be /etc/sms/services/vstream.
The issues for normal users are standard for sms_client.
You get problems like cant open log file, lock file, modem device.
On my system I get around this by making the sms_client binary
set-gid uucp, and make /var/log/smslog writable by group uucp.


Note You need to log in before you can comment on or make changes to this bug.