Bug 527281 - "/sbin/mdadm --detail --export /dev/md0" segfaults
"/sbin/mdadm --detail --export /dev/md0" segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-05 13:58 EDT by John Ellson
Modified: 2009-11-05 16:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 16:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2009-10-05 13:58:33 EDT
Description of problem:
During boot there are two complaints about mdadm:

    Starting udev: Gudevd-work[424]: '/sbin/mdadm --detail --export /dev/md0' unexpected exit with status 0x000b

    ip6tables: Applying firewall rules: udevd-work[794]: '/sbin/mdadm --detail --export /dev/md0' unexpected exit with status 0x000b

Boot is successfull and /dev/md0 raid device is mounted OK.

The problem with mdadm can be reproduced from the command line:

Version-Release number of selected component (if applicable):
mdadm-3.0-1.fc11.i586

How reproducible:
100%

Steps to Reproduce:
1. /sbin/mdadm --detail --export /dev/md0
2.
3.
  
Actual results:
MD_LEVEL=raid0
MD_DEVICES=2
MD_METADATA=0.90
MD_UUID=9b3b625f:46202f85:a84f4713:83bb1a00
Segmentation fault


Expected results:
no segfaults

Additional info:

I tried running under gdb, but it wants me to:
  debuginfo-install mdadm-3.0-4.fc12.i686

When I do that I get:

Package(s) data still to download: 11 M
(1/2): glibc-debuginfo-2.10.90-24.i686.rpm                                          |  11 MB     00:19     
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/debug/glibc-debuginfo-2.10.90-24.i686.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(2/2): mdadm-debuginfo-3.0-4.fc12.i686.rpm                                          | 471 kB     00:01     
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/debug/mdadm-debuginfo-3.0-4.fc12.i686.rpm: (-1, u'Package does not match intended download')
Comment 1 Doug Ledford 2009-11-05 13:54:02 EST
This should be resolved in mdadm-3.0.3-1

Note You need to log in before you can comment on or make changes to this bug.