Bug 527519 - Blutooth update disables keyboard and mouse features
Blutooth update disables keyboard and mouse features
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 14:44 EDT by Maxwell Bottiger
Modified: 2009-11-04 11:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 11:04:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxwell Bottiger 2009-10-06 14:44:39 EDT
Description of problem:
After an update the extra keys on my bt keyboard and mouse, along with the scroll wheel on my mouse have stopped working.  This has happened before due to bluetooth updates, but was corrected back in August.

Version-Release number of selected component (if applicable):
bluez-4.42-6.fc11.x86_64
bluez-libs-4.42-6.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot system, click a button or type a character to wake up the connection between the PC and peripherals
2. Peripherals work only in basic mode (not HID)
3.
  
Actual results:
Basic functions are just fine, but no scroll wheel is irritating.  Gnome bluetooth manager is not loading anymore

Expected results:
All the buttons work as they did 2 days ago.


Additional info:
I'm using a pretty standard Dell BT keyboard and mouse.  Like I said earlier, this was a problem with an update a couple months back, but this bug went away for a while.  It looks like it may be the same problem, or perhaps something similar.
Comment 1 Bastien Nocera 2009-11-02 14:48:23 EST
Please test with:
http://koji.fedoraproject.org/koji/buildinfo?buildID=139403
Comment 2 Maxwell Bottiger 2009-11-04 10:43:08 EST
My keys are all working, and the scroll wheel is back.  Life is good, thank you so much!
Comment 3 Bastien Nocera 2009-11-04 11:04:24 EST
Errata has been pushed to stable:
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-10931

Enjoy.

Note You need to log in before you can comment on or make changes to this bug.