Bug 527552 - GError and TypeError: Parsing primary.xml error: attributes construct error
GError and TypeError: Parsing primary.xml error: attributes construct error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 18:00 EDT by David Timms
Modified: 2014-01-21 18:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.1.2-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 07:10:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
terminal log during preupgrade getting boot and packages (5.03 KB, text/plain)
2009-10-06 18:00 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2009-10-06 18:00:51 EDT
Created attachment 363903 [details]
terminal log during preupgrade getting boot and packages

Description of problem:
Noted some (seemingly non-critical) warnings spewed to terminal during preupgrade gui process.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.30.5-43.fc11.i686
preupgrade-1.1.0-1.fc11.noarch
yum-3.2.23-3.fc11.noarch

How reproducible:
haven't tried.

Steps to Reproduce:
1. install F11
2. update to current updates
3. start terminal and run preupgrade
4. choose show me dev releases, and select rawhide
5. next

Actual results:
1. GError issues:
/usr/lib/python2.6/site-packages/sqlitecachec.py:45: Warning: GError set over the top of a previous GError or uninitialized memory.

2. traceback:
  File "/usr/lib/python2.6/site-packages/createrepo/__init__.py", line 829, in doRepoMetadata
    rp.getPrimary(complete_path, csum)
  File "/usr/lib/python2.6/site-packages/sqlitecachec.py", line 45, in getPrimary
    self.repoid))
TypeError: Parsing primary.xml error: attributes construct error

Expected results:
No errors.
Comment 1 seth vidal 2009-10-07 00:54:35 EDT
yum 3.2.24 in f11 updates solves this problem.
Comment 2 David Timms 2009-10-11 01:25:23 EDT
Retested with:
yum-3.2.24-2.fc11.noarch
preupgrade-1.1.0-1.fc11.noarch
The above warnings and traceback are no longer seen.

The only unexpected message is warning for the future development...

# preupgrade
/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, refresh-packagekit, whiteout
Detected in-progress upgrade to Rawhide
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=i386
Comment 3 Will Woods 2009-10-12 11:06:07 EDT
Sorry to reopen but I've hit the same bug on F10; any plans to update F10 to yum-3.2.24?
Comment 4 seth vidal 2009-10-12 11:10:00 EDT
you hit the same bug going f10->f11 or f10-rawhide/f12?
Comment 5 Will Woods 2009-10-12 11:20:17 EDT
F10->Rawhide. Why? Is the problem caused by F10 yum having trouble with the repodata/package headers/etc from F12?
Comment 6 seth vidal 2009-10-12 11:23:07 EDT
It's a package in f12/rawhide that's tripping up yum/createrepo.
Comment 7 James Laska 2009-10-15 16:41:56 EDT
Discussed with wwoods who suggested this might be good to note for users going from F10->rawhide using preupgrade.  Adding the keyword so this lands on the CommonBugs? radar.
Comment 8 Fedora Update System 2009-10-20 17:05:51 EDT
preupgrade-1.1.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.1.2-1.fc10
Comment 9 Will Woods 2009-10-20 17:13:19 EDT
yum-3.2.24 has been submitted as an update for F10; preupgrade-1.1.2-1.fc10 just requires the newer yum, which has the fix.
Comment 10 Fedora Update System 2009-10-27 02:59:20 EDT
preupgrade-1.1.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10803
Comment 11 Fedora Update System 2009-11-04 07:10:05 EST
preupgrade-1.1.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Adam Williamson 2009-11-17 02:57:46 EST
so there's nothing needing to be common_bugs documented now, right?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.