Bug 52762 - Many modules files are not deleted.
Summary: Many modules files are not deleted.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 20:02 UTC by hjl
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 20:02:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hjl 2001-08-28 20:02:22 UTC
In the kernel spec file, there are many

# grep "#rm -f" kernel-2.4.spec
#rm -f /lib/modules/%{KVERREL}/modules.*
#rm -f /lib/modules/%{KVERREL}BOOT/modules.*
#rm -f /lib/modules/%{KVERREL}jensen/modules.*
#rm -f /lib/modules/%{KVERREL}tape/modules.*
#rm -f /lib/modules/%{KVERREL}BOOTtape/modules.*

As the result, I got

modules.dep             modules.isapnpmap   modules.pcimap
modules.generic_string  modules.parportmap  modules.usbmap

under /lib/modules/deleted-kernel-version.

Comment 1 Arjan van de Ven 2001-08-28 20:07:34 UTC
Known, and annoying problem.
Some of the kernels had those files in the rpm, others didn't.
End result: either we left files behind, or RPM got upset because it tried to
remove files the %preun just removed.

Sweet end: I had time to fix this last saturday afternoon and I've tested
several kernels... seems to work.


Note You need to log in before you can comment on or make changes to this bug.