Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 527657 - Conflict between emacs and openmpi
Summary: Conflict between emacs and openmpi
Keywords:
Status: CLOSED DUPLICATE of bug 496131
Alias: None
Product: Fedora
Classification: Fedora
Component: openmpi
Version: 11
Hardware: i586
OS: Linux
low
low
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-07 07:55 UTC by Josip Šumečki
Modified: 2014-01-21 23:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-20 18:24:57 UTC
Type: ---


Attachments (Terms of Use)

Description Josip Šumečki 2009-10-07 07:55:14 UTC
Description of problem:

When I tried to install openMPI with "yum install openmpi", i got confict error:
==============================
Transaction Check Error:
  file /usr/bin/otfdump from install of openmpi-1.3.1-1.fc11.i586 conflicts with file from package libotf-0.9.8-2.fc11.i586

Error Summary
-------------
==============================

I did "yum remove libotf" and yum removed emacs also (because libotf is dependency of emacs) and installed openmpi without any problem.
Now, of course, "yum install emacs" gives similar output:
==============================
Transaction Check Error:
  file /usr/bin/otfdump from install of libotf-0.9.8-2.fc11.i586 conflicts with file from package openmpi-1.3.1-1.fc11.i586

Error Summary
-------------
==============================

Version-Release number of selected component (if applicable):
$ yum --version
3.2.24
  Installed: rpm-4.7.1-1.fc11.i586 at 2009-10-04 10:43
  Built    : Fedora Project at 2009-07-24 05:07
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2009-07-23 12:00

  Installed: yum-3.2.24-2.fc11.noarch at 2009-10-04 10:48
  Built    : Fedora Project at 2009-09-21 19:27
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2009-09-21 12:00

  Installed: yum-metadata-parser-1.1.2-12.fc11.i586 at 2009-10-04 10:14
  Built    : Fedora Project at 2009-02-25 18:45
  Committed: Fedora Release Engineering <rel-eng@lists.fedoraproject.org> at 2009-02-25 22:00


How reproducible:
Enter steps shown below...

Steps to Reproduce:
1. full update fedora 11 i586
2. yum install emacs
3. yum install openmpi
  
Actual results:
conflict between emacs and openmpi

Expected results:
both emacs and openmpi installed

Additional info:

Comment 1 James Antill 2009-10-07 13:28:17 UTC
Picking one package randomly.

Comment 2 Michael Ploujnikov 2009-10-20 01:49:18 UTC
This is probably a duplicate of #496131.

Comment 3 Doug Ledford 2009-10-20 18:24:57 UTC

*** This bug has been marked as a duplicate of bug 496131 ***


Note You need to log in before you can comment on or make changes to this bug.