Bug 527670 - Huge Page Backed Memory Failed for Kqemu Guests
Huge Page Backed Memory Failed for Kqemu Guests
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 05:58 EDT by CAI Qian
Modified: 2009-10-07 07:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 07:10:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest XML file (1.48 KB, text/plain)
2009-10-07 05:58 EDT, CAI Qian
no flags Details

  None (edit)
Description CAI Qian 2009-10-07 05:58:33 EDT
Created attachment 363941 [details]
guest XML file

Description of problem:
After configured hugepages for a kqemu guest, there is no sign of hugepages usage when starting the guest.

# cat /proc/meminfo
...
HugePages_Total:     600
HugePages_Free:      600
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
...

Does hugepages suppose to be working there?

Version-Release number of selected component (if applicable):
libvirt-0.7.1-8.fc12.x86_64
kqemu-1.4.0pre1
qemu-0.11.0-3.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. configure hugepages in the host.
2. virsh edit <guest> to use hugepages backed memory.
3. virsh start <guest>.
4. check /proc/meminfo
  
Actual results:
HugePages_Free is not reduced.

Expected results:
HugePages_Free should be reduced.
Comment 1 Daniel Berrange 2009-10-07 06:12:10 EDT
Do you really mean kqemu and not kvm ?  

We do not ship kqemu in Fedora, and upstream QEMU has deleted all code relating to kqemu so its use is not supported in any way, nor likely tobe in the future.
Comment 2 CAI Qian 2009-10-07 07:03:26 EDT
(In reply to comment #1)
> Do you really mean kqemu and not kvm ?  

Yes.

> 
> We do not ship kqemu in Fedora, and upstream QEMU has deleted all code relating
> to kqemu so its use is not supported in any way, nor likely tobe in the future.  

The module was downloaded here,
http://www.nongnu.org/qemu/download.html
Comment 3 Daniel Berrange 2009-10-07 07:10:17 EDT
Ok, well kqemu doesn't use hugepages, and since its dead upstream, we don't intend to enhance it todo so.

Note You need to log in before you can comment on or make changes to this bug.