Bug 52782 - control-center-1.4.0.1-16 does not build (capplet.pc missing)
control-center-1.4.0.1-16 does not build (capplet.pc missing)
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: control-center (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 21:15 EDT by Christian Hechelmann
Modified: 2013-04-02 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-29 09:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Hechelmann 2001-08-28 21:15:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
control-center-1.4.0.1-16 does not build because capplet.pc is missing
and control-center-single-0.3 looks for it via pkgconfig. capplet.pc is 
neither mentioned in the spec nor in the control-center sources.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild control-center-1.4.0.1-16.src.rpm
2. build bombs with an error as sson as control-center-single-0.3's
   configure is run.
3.
	

Actual Results:  
+ cd control-center-single-0.3
+ automake
+ autoconf
+ CFLAGS=-O2 -m486 -fexpensive-optimizations
+ export CFLAGS
+ CXXFLAGS=-O2 -m486 -fexpensive-optimizations
+ export CXXFLAGS
+ FFLAGS=-O2 -m486 -fexpensive-optimizations
+ export FFLAGS
+ '[' -f configure.in ']'
+ libtoolize --copy --force
You should update your `aclocal.m4' by running aclocal.
+ ./configure i386-redhat-linux --prefix=/usr --exec-prefix=/usr --
bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --
datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --
libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --
mandir=/usr/share/man --infodir=/usr/share/info
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -m486 -fexpensive-optimizations ) 
works... yes
checking whether the C compiler (gcc -O2 -m486 -fexpensive-optimizations ) 
is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for strerror in -lcposix... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for Cygwin environment... no
checking for mingw32 environment... no
checking host system type... i386-redhat-linux-gnu
checking build system type... i386-redhat-linux-gnu
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependant libraries... pass_all
checking for object suffix... o
checking for executable suffix... no
checking command to parse /usr/bin/nm -B output... ok
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... 
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking for pkg-config... /usr/bin/pkg-config
checking for gnome >= 1.0.60... yes
checking LIBGNOME_CFLAGS... -DNEED_GNOMESUPPORT_H -I/usr/include -
I/usr/lib/gnome-libs/include -I/usr/include/gtk-1.2 -I/usr/include/glib-
1.2 -I/usr/lib/glib/include -I/usr/X11R6/include  
checking LIBGNOME_LIBS...  -L/usr/lib -lgnome -lgnomesupport -lesd -
laudiofile -lm -ldb1 -lglib -ldl  
checking for gnomeui >= 1.0.60... yes
checking GNOMEUI_CFLAGS... -DNEED_GNOMESUPPORT_H -I/usr/include -
I/usr/lib/gnome-libs/include -I/usr/include/gtk-1.2 -I/usr/include/glib-
1.2 -I/usr/lib/glib/include -I/usr/X11R6/include  
checking GNOMEUI_LIBS...  -rdynamic  -L/usr/lib -L/usr/X11R6/lib -
lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -lXi -
lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1 -lglib -
ldl  
checking for capplet... Package capplet was not found in the pkg-config 
search path.
Perhaps you should add the directory containing `capplet.pc'
to the PKG_CONFIG_PATH environment variable
No package 'capplet' found

configure: error: Library requirements (capplet) not met; consider 
adjusting the PKG_CONFIG_PATH environment variable if your libraries are 
in a nonstandard prefix so pkg-config can find them.
Fehler: Bad exit status from /pub/disk1/rpmtmp/rpm-tmp.34503 (%build)


RPM build errors:
    Bad exit status from /pub/disk1/rpmtmp/rpm-tmp.34503 (%build)
[drdisk@junkyard redhat]$ 



Expected Results:  successful build


Additional info:

The following packages needed by control-center where installed at the 
time of build:

gcc-2.96-96
audiofile-0.2.1-2
aumix-2.6.1-2
control-center-1.4.0.1-13
db1-1.85-7
esound-0.2.22-5
GConf-1.0.4-1
gdk-pixbuf-0.11.0-8
glib-1.2.10-5
glibc-2.2-12
gnome-libs-1.2.13-14
gnome-vfs-1.0.1-16
gtk+-1.2.10-10
imlib-1.9.10-2
libjpeg-6b-16
libpng-1.0.12-2
libtiff-3.5.5-12
libungif-4.1.0-9
libxml-1.8.14-2
oaf-0.6.5-8
ORBit-0.5.8-4
popt-1.6.3-0.93
XFree86-libs-4.0.3-5
xscreensaver-3.33-3
zlib-1.1.3-24
Comment 1 Havoc Pennington 2002-03-04 16:15:38 EST
control-center isn't self hosting. Because we're dumping this package on the
move to GNOME 2 anyhow, and it's sort of hard to fix, we're just going to let
the problem go away when the package goes away.

Note You need to log in before you can comment on or make changes to this bug.