This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 527859 - RFE: rebase zsh for the newer utf-8 support
RFE: rebase zsh for the newer utf-8 support
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: zsh (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 20:21 EDT by Ding-Yi Chen
Modified: 2013-03-26 11:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 11:43:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2009-10-07 20:21:00 EDT
Description of problem:
zsh older than 4.3.1 does not handle  the inputting utf8 string properly.
Thus the inputting utf8 string looks messy.


Version-Release number of selected component (if applicable):
zsh-4.2.6-3.el5


How reproducible:
Always


Steps to Reproduce:
1. In gnome-terminal, with zsh as current shell.
2. copy the string "中文" (chinese)
3. past in zsh
  
Actual results:
The screen showing the string 中�^�^  


Expected results:
The screen showing the string 中文

Additional info:
I've also built and tried zsh-4.3.10 in RHEL5, it works for me.
So maybe you can consider upgrade the zsh.
Comment 1 James Antill 2009-10-08 00:05:10 EDT
This is unlikely to be added, as it's such a big change and would likely break something.
Comment 2 Ding-Yi Chen 2009-10-08 19:36:58 EDT
That's why I seek professional opinion.  :-)

After your investigation, if you still feel that the upgrade is inappropriate, though it is a pity, I understand.
Comment 3 Jan Zeleny 2013-03-26 11:43:02 EDT
As James indicated in comment 1, this is rather big change and it has potential to break things. Since we are now in very late stage of RHEL5 development cycle, this is unacceptable. I'm sorry but I have to close the bug, it won't be addressed in RHEL5.

Note You need to log in before you can comment on or make changes to this bug.