Bug 527920 - gdm doesn't show user list and crashes - unable to login
Summary: gdm doesn't show user list and crashes - unable to login
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs, Reopened
: 529778 530041 (view as bug list)
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
Reported: 2009-10-08 08:42 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2013-01-10 05:31 UTC (History)
15 users (show)

Clone Of:
Last Closed: 2010-02-23 06:18:34 UTC

Attachments (Terms of Use)
gdm greeter log (21.59 KB, text/plain)
2009-10-08 08:42 UTC, Dominik 'Rathann' Mierzejewski
no flags Details
gdm slave log (9.17 KB, text/plain)
2009-10-08 08:42 UTC, Dominik 'Rathann' Mierzejewski
no flags Details
GDM Screenshot (710.01 KB, image/png)
2009-10-14 18:46 UTC, James Laska
no flags Details

Description Dominik 'Rathann' Mierzejewski 2009-10-08 08:42:10 UTC
Created attachment 364066 [details]
gdm greeter log

Description of problem:
On a fully updated rawhide installation configured with LDAP authentication and no local users, gdm shows no user list and no "other" button. If I type my username "blindly", it shows a small input box where the letters that I'm typing appear, but nothing happens after I press Enter. If I just click "Login", it crashes.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install current rawhide
2. configure ldap authentication with no local users
3. try to login
Actual results:
There's no user list and no other option to login.

Expected results:
There should be a visible user list or at least an input box to type username and password.

Additional information:
Logging on a VT and running startx works fine.

Comment 1 Dominik 'Rathann' Mierzejewski 2009-10-08 08:42:42 UTC
Created attachment 364067 [details]
gdm slave log

Comment 2 Dominik 'Rathann' Mierzejewski 2009-10-08 11:53:26 UTC
I think this is serious enough to block the Beta. An inexperienced user won't know they can login on a VT and run startx.

Comment 3 Jesse Keating 2009-10-08 17:44:14 UTC
An inexperienced user won't likely have setup their system for LVM auth and no local users.  I'm not inclined to slip the beta for this issue.

Comment 4 Ray Strode [halfline] 2009-10-09 16:18:18 UTC
This should be fixed in gdm-2.28.0-9.fc12

Comment 5 James Laska 2009-10-09 16:41:27 UTC
Reviewed during F-12 beta blocker meeting and accepted to F12Beta.

Comment 6 Dominik 'Rathann' Mierzejewski 2009-10-12 09:44:22 UTC
(In reply to comment #4)
> This should be fixed in gdm-2.28.0-9.fc12  

Sorry, it isn't. Still the same issue.

Comment 7 James Laska 2009-10-14 18:46:06 UTC
Created attachment 364788 [details]
GDM Screenshot

With gdm-2.28.0-9.fc12 installed, on a system configured for NIS and krb5 auth, I am not prompted to enter a user name.

Comment 8 James Laska 2009-10-14 18:47:10 UTC
Moving back to ASSIGNED based on comment#6 and comment#7.  The reported problem seems to remain.

Comment 9 Ray Strode [halfline] 2009-10-14 19:23:10 UTC
That's unfortunate.  I will need to investigate further.

Unfortunately, we're too late to make the beta at this point.

A couple of possible workarounds:

1) Log in once on tty2
2) Add the NIS user to /etc/passwd temporarily.

Comment 10 Dominik 'Rathann' Mierzejewski 2009-10-15 16:35:22 UTC
(In reply to comment #9)
> A couple of possible workarounds:
> 1) Log in once on tty2
> 2) Add the NIS user to /etc/passwd temporarily.  

3) yum -y install kdm && echo "DISPLAYMANAGER=KDE" > /etc/sysconfig/desktop

Comment 11 Thomas J. Baker 2009-10-21 18:38:15 UTC
The latest build from koji gdm-2.28.1-3.fc12.x86_64 does not fix the problem. Logging in on tty2 first does not help either.

Comment 12 Andrew McNabb 2009-10-21 19:00:11 UTC
*** Bug 529778 has been marked as a duplicate of this bug. ***

Comment 13 Andrew McNabb 2009-10-21 19:08:05 UTC
(In reply to comment #9)
> A couple of possible workarounds:
> 1) Log in once on tty2

Logging in once on tty2 and restarting gdm did not add the user to the login screen.

Comment 14 Peter Glassenbury 2009-10-22 01:56:00 UTC
I have set up for ldap... I tried to not use it by
taking all ldap references out of /etc/nsswitch.conf

After reboot, no difference to the login screen. Still no 
user list, other button or box to enter username.

Comment 15 Terje Røsten 2009-10-22 19:10:34 UTC
This is most funny bug I seen in a while, if my system is setup with nis or ldap auth I end up with screenshot from comment #7. An impossible login screen.

KDM works, however has another bug, it wants to mount all $HOME dirs to check Something(TM). Now combine that with the slower nfs mount thingie in F12 and lots of users in the domain and it's takes a loooooong time to login.

In the good old days of shared homes on NFS and automounts things like this worked great, in the laptop centric world today (which don't really need GDM/KDE at all, in fact :-) programmers don't seems to care. Without login working it's a bit difficult to test rest of the beta :-)

Well, well. Why not use gdm 2.26.1 from F11, it seems to work.

Comment 16 Alexander Boström 2009-10-26 09:21:35 UTC
With gdm-2.28.1-5.fc12.x86_64 my login screen looks just like on the screenshot, but my system is not set up to use any remote user database like LDAP or NIS.

# rpm -Vf /etc/nsswitch.conf /etc/gdm/custom.conf 
.M....G..    /var/log/gdm
.M.......    /var/run/gdm

So default configs as far as I can see.

Comment 17 Ray Strode [halfline] 2009-10-26 20:58:40 UTC
This should be set as of 2.28.1-7

Comment 18 Andrew McNabb 2009-10-26 21:24:38 UTC
I just installed 2.28.1-10 from koji, and I'm still seeing the problem.  The only differences are that the Suspend/Restart/Shut Down buttons moved down to a menu next to the clock, and it now gives the system release instead of saying "localhost.localdomain".  However, there is still no "Other" box.

Comment 19 Terje Røsten 2009-10-27 11:24:24 UTC
Same here with nis auth.

$ rpm -q gdm

Still at screenshot from comment #7, with Suspend/Restart/Shut Down moved.

Of course it's not possible to login.

 - Terje

Comment 20 Ray Strode [halfline] 2009-10-27 20:01:40 UTC
Alright, please give -12 a try.

Comment 21 Andrew McNabb 2009-10-27 20:22:42 UTC
rstrode, it looks like -12 works great.  I saw the "Other" entry, a spot to enter a Username, and I was able to login.  Thanks!

Comment 22 Terje Røsten 2009-10-28 07:54:39 UTC
$ rpm -q gdm

Works fine here too, thanks!

Comment 23 Adam Williamson 2009-10-28 17:13:22 UTC
12.fc12 has been tagged, so I think we can close this. If anyone's still having trouble with that version, please re-open.

Fedora Bugzappers volunteer triage team

Comment 24 Dominik 'Rathann' Mierzejewski 2009-10-30 00:24:47 UTC
I've tried -12 and the problem is still there. There's still no user list and the only button that's visible is "Login", which obviously does nothing since I can't input user name or password.

Comment 25 Ray Strode [halfline] 2009-10-30 00:51:08 UTC
Dominik, did you reboot after upgrading?

Comment 26 Dominik 'Rathann' Mierzejewski 2009-10-30 00:57:31 UTC
No, I only did init 3 ; init 5. Why would I need a reboot?

Comment 27 Ray Strode [halfline] 2009-10-30 01:13:58 UTC
init 3; init 5

Should be fine, unless the old gdm got stuck because of some other bug.

Since others reported it's working for them, I just wanted to make sure the new GDM was running on you machine.

Can you tell me more about your set up?

Do you use NIS? ldap? do you have any local users?

What's the output of 

rpm -qa |grep gdm

(which plugins are installed)?

Can you attach /etc/sysconfig/authconfig ?

Comment 28 Adam Williamson 2009-10-30 17:29:04 UTC
Dominik, can you provide the required info ASAP? This is on the F12 blocker list and we are running out of time for final (we need everything in by Wednesday at the latest). Thanks!

Fedora Bugzappers volunteer triage team

Comment 29 Matthias Clasen 2009-10-30 22:37:49 UTC
Moving this to Ray, whose working on gdm atm.

Comment 30 Adam Williamson 2009-11-03 16:59:15 UTC
If Dominik doesn't provide the requested info by tonight (my time, PST) i'm going to drop this from the blocker list, since others reported that it was fixed and I haven't seen any new reports of this trouble I'm inclined to suspect it's an issue more specific to Dominik's configuration...

Fedora Bugzappers volunteer triage team

Comment 31 Terje Røsten 2009-11-03 19:53:32 UTC
Did a new test install, this time with LDAP auth, GDM works fine.

Comment 32 Ray Strode [halfline] 2009-11-03 21:53:01 UTC
Hi Dominik,

I'm going to go ahead and close this bug


If you continue to have issues, please file a new report.

Comment 33 Andrew McNabb 2009-11-24 20:37:50 UTC
*** Bug 530041 has been marked as a duplicate of this bug. ***

Comment 34 Jari Kuisma 2009-12-03 12:46:29 UTC
Closed but not fixed. After upgrading from F11 to F12 (by preupgrade) I have similar problems as Dominik: no buttons on login screen and no user list. There is only "login" field on screen showing text "Other", but I can not write anything in it. Whole screen is "blinking", actually it seems that gdm-passwd process is crashing and restarting continiously.

Logging on a VT and running startx works fine for me too.

I am using NIS, but for some historical reasons I have created my account locally, too. Same uid and gid as NIS user has.

Comment 35 Ray Strode [halfline] 2009-12-03 15:06:28 UTC
Hi, would you mind trying the gdm in F12 updates-testing ?  It fixes a crasher bug.

Comment 36 Peter Glassenbury 2009-12-04 04:17:47 UTC
Interesting effect..
Installed F12 ISO. with the users add to ldap.conf [bug 502072], I can login OK.
Installed the F12 updates. can no longer get a login box. "other.." is on the
screen but no username box

#yum --enablerepo=updates-testing update gdm
 gdm  x86_64       1:2.28.1-25.fc12  updates-testing 1.0 M
Updating for dependencies:
 gdm-plugin-fingerprint  x86_64 1:2.28.1-25.fc12  updates-testing 91 k

reboot.. and username box is back again and can login OK

Comment 37 Jari Kuisma 2009-12-04 06:16:30 UTC
Great, gdm-2.28.1-25 fixed my login screen too! Thank you!

Note You need to log in before you can comment on or make changes to this bug.