Bug 52794 - Windowmaker load/save layout fails
Summary: Windowmaker load/save layout fails
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-29 05:17 UTC by Dietmar Lettau
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 21:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dietmar Lettau 2001-08-29 05:17:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When installing Windowmaker, two files are created in the $HOME/GNUstep-
Directory which contain non valid information. The files are 
Defaults/WMRootMenu Library/WindowMaker/plmenu.de , the wrong information 
is the path "/home/mawa" instead of "$HOME".

Greetings
Dietmar Lettau

Version-Release number of selected component (if applicable):
? That used in RH7.1

How reproducible:
Always

Steps to Reproduce:
1. Choose save Layout
2. Choose load layout


Actual Results:  Error is visible in the .X.err -File


Expected Results:  The files should be loaded from $HOME..., not 
from /home/mawa, cause this seems to be the home-Directory of the guy who 
programmed that stuff.

Additional info:

"perl -p -i -e 's/\/home\/mawa/\$HOME/g' Defaults/WMRootMenu 
Library/WindowMaker/plmenu.de"
fixes the problem ;-)

Comment 1 Phil Copeland 2002-02-15 03:30:08 UTC
I'll (eventually) get around to backporting the rawhide version to 7.0/7.1/7.2

If you can't wait that long, the SRPM is available
ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/
WindowMaker-0.80.0-5.src.rpm

There should be some apps to go with it in the tree later tonight (wmix /
wmclock / wmapm)

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.