Bug 52800 - Saved games are not reloaded
Summary: Saved games are not reloaded
Status: CLOSED DUPLICATE of bug 20454
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: nethack   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-29 12:33 UTC by Nicolau C. Saldanha
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-29 12:33:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolau C. Saldanha 2001-08-29 12:33:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
When you save a game, nethack creates a file with a name similar to
/usr/lib/games/nethackdir/save/1007nicolau.bz2
When you try to restart the game, it says
Version mismatch for file "save/1007nicolau"
deletes the save-game-file and starts a new game.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a game (with the cammand 'nethack')
2. Save (type 'S')
3. Try to restart ('nethack')
 	

Actual Results:  A new game is started and the file
/usr/lib/games/nethackdir/save/1007nicolau.bz2
is deleted.

Expected Results:  The old game should have resumed from the point the
player saved.

Additional info:

The program does not seem to be handling the *.bz2 files properly
(even though bzip2 is installed). I succeeded in producing a working
version of nethack by the following steps.

Untar the file nethack-331.tgz (from nethack nethack-3.3.1-3.src.rpm).

Apply the patch nethack-3.3.1-redhat.patch (again from *.src.rpm).

Edit the file include/config.h and commented out the lines that told
nethack to use bzip2. More precisely I changed from

#ifdef UNIX                                                               
     /* path and file name extension for compression program */
#define COMPRESS "/usr/bin/bzip2"  /* bzip2 compression */                
     #define COMPRESS_EXTENSION ".bz2"  /* bzip2's extension */           
          /* An example of one alternative you might want to use: */
/* #define COMPRESS "/bin/gzip" */      /* FSF gzip compression */
/* #define COMPRESS_EXTENSION ".gz" */  /* normal gzip extension */
#endif                                                                    
     

to:

#ifdef UNIX                                                               
     /* path and file name extension for compression program */
/* #define COMPRESS "/usr/bin/bzip2" */ /* bzip2 compression */
/* #define COMPRESS_EXTENSION ".bz2" */ /* bzip2's extension */
/* An example of one alternative you might want to use: */
/* #define COMPRESS "/bin/gzip" */      /* FSF gzip compression */
/* #define COMPRESS_EXTENSION ".gz" */  /* normal gzip extension */
#endif                                                                    
     

This is telling nethack to use either no compression
or some built in compression, not sure which.

We are now ready:

cd nethack-3.3.1/sys/unix/
./setup.sh
cd ../..
make

Finally, as root,

make install

nethack now appears to work!

Comment 1 Bernhard Rosenkraenzer 2001-08-29 14:22:00 UTC

*** This bug has been marked as a duplicate of 20454 ***


Note You need to log in before you can comment on or make changes to this bug.