This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528094 - qt webkit crash on drag
qt webkit crash on drag
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-08 22:05 EDT by William Witt
Modified: 2009-12-20 03:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-20 03:13:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix webkit drag crash (1.54 KB, application/octet-stream)
2009-10-08 23:50 EDT, William Witt
no flags Details

  None (edit)
Description William Witt 2009-10-08 22:05:39 EDT
Description of problem:
qtwebkit crashes when items are dragged out of it.

http://code.google.com/p/arora/issues/detail?id=530
Comment 1 William Witt 2009-10-08 23:50:10 EDT
Created attachment 364191 [details]
patch to fix webkit drag crash

patch taken from git://gitorious.org/qt/qt.git commit 9dadc219814cd9baaa4be4cee6ee2b3cf7df4a19

git log is as follows:

commit 9dadc219814cd9baaa4be4cee6ee2b3cf7df4a19
Author: Simon Hausmann <simon.hausmann@nokia.com>
Date:   Fri Jul 24 10:22:11 2009 +0200

    Updated WebKit from /home/shausman/src/webkit/trunk to origin/qtwebkit-4.5 ( eb3afcbfb4006de4015047555cb256fcde93b954 )

    Changes in WebKit since the last update:

    ++ b/WebCore/ChangeLog
    2009-05-27  John Sullivan  <sullivan@apple.com>

            fixed <rdar://problem/6925482> repro crash in WebCore::DragController::dragExited dropping
            bookmarks (at least) over Top Sites (at least)

            Reviewed by Kevin Decker

            * page/DragController.cpp:
            (WebCore::DragController::dragExited):
            nil check m_documentUnderMouse and take the "local file" case if it's nil
Comment 2 Rex Dieter 2009-10-09 00:13:25 EDT
I can't reproduce any crash here. ??

$ rpm -q arora qt
arora-0.10.1-1.fc11.x86_64
qt-4.5.2-21.fc11.x86_64
Comment 3 William Witt 2009-10-09 10:05:50 EDT
Where did you get qt-4.5.2-21.fc11.x86_64?  The newest qt in the F11 repositories is qt-4.5.2-3.fc11 which does have the bug.
Comment 4 Rex Dieter 2009-10-09 10:08:08 EDT
Oh, yeah, my own backported build of what's currently in F-12/rawhide.

Still, the bug *should* still be present there.  Do you have a recipe to reproduce the crash?

In the meantime, the patch looks fairly sane, but I'd rather have comment from one of my fellow qt maintainers before applying it.
Comment 5 Rex Dieter 2009-10-09 10:16:07 EDT
If you want to test for yourself, the newer experimental qt builds are here:
http://kde-redhat.unl.edu/apt/kde-redhat/fedora/11/
in the unstable repo
Comment 6 William Witt 2009-10-09 10:55:36 EDT
Tested with qt from http://kde-redhat.unl.edu/apt/kde-redhat/fedora/11/ and can still reproduce.  Please try the following:

-open arora (I use arora from git, but the bug was present using 0.9.0 and 0.10.0 as well)

-click and drag a bookmark from the bookmark bar.

-drag the bookmark over the webview and back out.

-arora will crash.


The patch is backported code from qt-4.5.3 if it make review any easier.
Comment 7 Rex Dieter 2009-10-09 10:59:00 EDT
> -arora will crash.

confirmed, thanks for the test-case.

> The patch is backported code from qt-4.5.3

oh cool, that puts me at ease then.  will apply.
Comment 8 Rex Dieter 2009-10-09 11:06:19 EDT
* Fri Oct 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-25
- qt webkit crash on drag (#528094)
Comment 9 Kevin Kofler 2009-10-09 11:22:00 EDT
If the fix is already in 4.5.3, the best solution would be to get Qt 4.5.3 out ASAP (but of course we need to sort out that translations mess). But sure, backporting fixes from 4.5.3 to 4.5.2 is safe.
Comment 10 Ngo Than 2009-10-13 07:17:02 EDT
the fix is already included in 4.5.3.
Comment 11 William Witt 2009-12-19 18:24:37 EST
It's been a while.  I din't realize the bug report was still open.  Verified fixed with current Fedora 12

Note You need to log in before you can comment on or make changes to this bug.