Bug 528187 - Error during yum install (anything) --downloadonly --downloaddir=.
Error during yum install (anything) --downloadonly --downloaddir=.
Status: CLOSED DUPLICATE of bug 506640
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-09 11:30 EDT by abohsin
Modified: 2014-01-21 18:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 11:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description abohsin 2009-10-09 11:30:12 EDT
Description of problem:
Following Error appears when using yum plugin download-only:
Loaded plugins: downloadonly, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 204, in getOptionsConfig
    (opts, self.cmds) = self.optparser.setupYumConfig(args=args)
  File "/usr/share/yum-cli/cli.py", line 1226, in setupYumConfig
    self.base._getRepos(doSetup=True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 455, in _getRepos
    self._repos.doSetup(thisrepo)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 41, in postreposetup_hook
    repo.setAttribute('pkgdir',opts.dldir)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 295, in setAttribute
    setattr(self, key, value)
AttributeError: can't set attribute


Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.yum install gcc --downloadonly --downloaddir=.
  
Additional info:
System is up-to-date.
Comment 1 seth vidal 2009-10-09 11:33:53 EDT
Can you give us the output of:

rpm -q yum yum-utils yum-plugin-downloadonly


but I think this is fixed:

https://bugzilla.redhat.com/show_bug.cgi?id=506640
Comment 2 James Antill 2009-10-09 11:54:33 EDT
100% this is a DUP of that.

*** This bug has been marked as a duplicate of bug 506640 ***
Comment 3 abohsin 2009-10-10 13:26:35 EDT
The system is up to date, that is everything is updated to latest release. I will post the output of the above command. I checked the bug number you posted earlier but I don't see a solution, can you tell me how it was solved or if it was a patch can you tell me what version in which repo it was solved, bug 506640 does not contain enough info on how it was solved.
Comment 4 Tim Lauridsen 2009-10-11 04:49:32 EDT
This should be fixed in 3.2.24.

http://yum.baseurl.org/gitweb?p=yum.git;a=commit;h=acc85de7d75ed00616ac79909551b5a19d243d37

Note You need to log in before you can comment on or make changes to this bug.