Bug 528217 - 12 hour clock shown in gdm even if locale default is 24 h
Summary: 12 hour clock shown in gdm even if locale default is 24 h
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 14
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 600778 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-09 20:14 UTC by Alexey Torkhov
Modified: 2015-01-14 23:23 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-12-14 13:56:36 UTC


Attachments (Terms of Use)

Description Alexey Torkhov 2009-10-09 20:14:50 UTC
Description of problem:
At gdm screen at 00:12 local time, I see 12:12 which, presumably, 12 hour clock format

$ cat /etc/sysconfig/i18n 
LANG="ru_RU.UTF-8"

Version-Release number of selected component (if applicable):
gdm-2.28.0-6.fc12.x86_64

Comment 1 Edward Sheldrake 2009-11-07 20:25:18 UTC
I think the date and time formats in gdm are handled by the translations, but Fedora's fix-clock.patch broke that by merging the format strings (date and time format were translated separately, plus date or time first is handled by another translation).

I just rebuilt gdm-2.28.1-24.fc12 without applying fix-clock.patch, and got a 24-hour clock and a date that nicely matches gnome-panel, in en_GB.

Comment 2 Edward Sheldrake 2009-11-07 21:27:50 UTC
Actually, I don't think fix-clock.patch was in gdm-2.28.0-6.fc12, the original report could be just due to the translation for "ru" not setting the 24-hour format.

Comment 3 Bug Zapper 2009-11-16 13:28:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Göran Uddeborg 2009-12-17 21:40:48 UTC
Running with LANG set to sv_SE.utf8, I also get a 12-hour clock.

The fix-clock.patch adds a lot of messages marked for translation, but there are no translations for them in any gdm.mo files.  I tried to add the following to the Swedish gdm.mo file:

msgid "%a %l:%M %p"
msgstr "%a %H:%M"

That helps!  Now I get a proper 24-hour clock!  The analysis in comment 1 seems to be confirmed.

So either the fix-clock.patch could be dropped, leaving the original time format, or the additional messages added in this patch could be made available for translation.  (I guess they aren't.  Or are they?)

translate.fedoraproject.org could surely handle the translation if you want to go that way.  But you would have to merge the additional translations with the original ones from upstreams.  It sounds a bit messy, but I may be wrong.

Comment 5 Sergey Rudchenko 2009-12-22 22:34:09 UTC
Thank you for the bug report.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Göran Uddeborg 2010-06-07 20:43:45 UTC
*** Bug 600778 has been marked as a duplicate of this bug. ***

Comment 7 Piotr Drąg 2010-06-08 11:25:12 UTC
Why exactly this patch can't be pushed upstream?

Comment 9 Piotr Drąg 2010-06-11 12:41:32 UTC
Oh, thanks then.

I don't think it is worthy to fix F12 (string freezes and such), but that's up to gdm maintainer.

Comment 10 Parag Nemade 2010-10-08 10:13:39 UTC
move this to f14 for triaging as gdm-2.30 is already built for f13 and f14

Comment 11 Piotr Drąg 2010-12-14 13:56:36 UTC
This bug is fixed in F13 and F14.


Note You need to log in before you can comment on or make changes to this bug.