Bug 528267 - Avoid explicit requires on mesa-libGL from compiz
Summary: Avoid explicit requires on mesa-libGL from compiz
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-10 12:29 UTC by Nicolas Chauvet (kwizart)
Modified: 2009-11-08 13:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-08 13:11:15 UTC
Type: ---


Attachments (Terms of Use)

Description Nicolas Chauvet (kwizart) 2009-10-10 12:29:47 UTC
Description of problem:
compiz.spec have:
---
Conflicts:	xorg-x11-server-Xorg < 1.3.0.0-19.fc8
Requires:	mesa-libGL >= 7.0.1-2.fc8
---
Thoses seems outdated Requires/Conflicts according that they mention fc8 which are EOL distro. Furthermore, refering the packaging guideline:

https://fedoraproject.org/wiki/Packaging:Guidelines#Explicit_Requires
"Packagers should revisit an explicit dependency as appropriate to avoid it becoming inaccurate and superfluous. For instance in the example above, when no current Fedora release shipped with libfubar < 1.2.3-7, it is no longer necessary to list the explicit, versioned requirement. "


Can you please avoid using theses outdated requires/Conflicts.

Comment 1 Nicolas Chauvet (kwizart) 2009-10-27 23:44:29 UTC
Re-Assigned to the current maintainer.

Comment 2 Adel Gadllah 2009-11-08 12:34:01 UTC
Fixed in compiz-0.8.2-19.fc13

Comment 3 Nicolas Chauvet (kwizart) 2009-11-08 12:40:45 UTC
No, it's not, you are still using Requires: mesa-libGL, that line must be deleted because the dependency extractor will pick the accurate shared object already.

Comment 4 Adel Gadllah 2009-11-08 13:10:35 UTC
(In reply to comment #3)
> No, it's not, you are still using Requires: mesa-libGL, that line must be
> deleted because the dependency extractor will pick the accurate shared object
> already.  

Right, fixed that in -20 and removed some other unneeded versioned requires.


Note You need to log in before you can comment on or make changes to this bug.