Bug 528269 - showmount -e clnt_create: RPC: Program not registered
showmount -e clnt_create: RPC: Program not registered
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-10 09:05 EDT by Flóki Pálsson
Modified: 2009-10-19 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-19 09:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace off showmount and results from showmond and xportfs -av (19.08 KB, text/plain)
2009-10-10 09:05 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2009-10-10 09:05:02 EDT
Created attachment 364342 [details]
strace off showmount and results from showmond and xportfs -av

Description of problem:
In f12 showmount -e 192.168.1.35 returns clnt_create: RPC: Program not registered. 192.168.1.35 is the host ip.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.0-16.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1.
 $  showmount -e 192.168.1.35
2.
3.
  
Actual results:
clnt_create: RPC: Program not registered

Expected results:
Show the NFS server’s export list.


Additional info:
See strace in attachment 

trying to get to f10 on another server 
[floki@flokipal ~]$ showmount -e 192.168.1.34
clnt_create: RPC: Unable to receive

using hostname
floki@flokipal ~]$ showmount -e flokipal
clnt_create: RPC: Program not registered

in f11 then this shows what nsf exports
Comment 1 Steve Dickson 2009-10-12 05:44:45 EDT
What does 'rpcinfo -p 192.168.1.35" show?
Comment 2 Flóki Pálsson 2009-10-14 19:43:07 EDT
[floki@flokipal ~]$ showmount -e 192.168.1.35
clnt_create: RPC: Program not registered
[floki@flokipal ~]$ rpcinfo -p 192.168.1.35
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  52179  status
    100024    1   tcp  58366  status
    100011    1   udp    875  rquotad
    100011    2   udp    875  rquotad
    100011    1   tcp    875  rquotad
    100011    2   tcp    875  rquotad
[floki@flokipal ~]$ 

ps
I have just finished reinstall off f12
Comment 3 Steve Dickson 2009-10-16 09:55:22 EDT
Ok... so the NFS server is not running if was there would be
the following rpcinfo -p entries:

    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
Comment 4 Flóki Pálsson 2009-10-16 14:57:18 EDT
I can not repeat this now.
In some cases system-config-services shows nfs running
but service status nfs says it stoped 

From
system-config-services 
when nfs is selected
The nfs service is started once, usually when the system is booted, runs in the background and wakes up when needed.
This service is enabled.
This service is running.
--
but 

[root@flokipal ~]# service --status-all | grep nfs
nfsd is stopped
[root@flokipal ~]# 

[root@flokipal ~]# service nfs status
rpc.mountd is stopped
nfsd is stopped
rpc.rquotad (pid 975) is running...
[root@flokipal ~]# 

-----------
after reboot
[floki@flokipal ~]$ su -
Password: 
[root@flokipal ~]# service nfs status
rpc.mountd (pid 1054) is running...
nfsd (pid 1051 1050 1049 1048 1047 1046 1045 1044) is running...
rpc.rquotad (pid 1039) is running...
[root@flokipal ~]# showmount -e 192.168.1.35
Export list for 192.168.1.35:
/mnt/ymislegt *
/mnt/tonlist  *
You have mail in /var/spool/mail/root
[root@flokipal ~]# 

---
another reboot
[floki@flokipal ~]$ su -
Password: 
[root@flokipal ~]# service --status-all | grep nfs
nfsd is stopped

nfs restarted from system-config-services 
[root@flokipal ~]# service --status-all | grep nfs
nfsd (pid 2784 2783 2782 2781 2780 2779 2778 2777) is running...
You have mail in /var/spool/mail/root
[root@flokipal ~]# 

[root@flokipal ~]# showmount -e 192.168.1.35
Export list for 192.168.1.35:
/mnt/ymislegt *
/mnt/tonlist  *
[root@flokipal ~]#
Comment 5 Steve Dickson 2009-10-19 09:02:19 EDT
Ok, I will close this as NOTABUG, but please feel 
free to reopen it if the problem comes back...
Comment 6 Flóki Pálsson 2009-10-19 16:20:38 EDT
>Ok, I will close this as NOTABUG, but please feel 
>free to reopen it if the problem comes back...  
the problem is there, I dot know how to reopen  

If service nfs is stopped then showmount returns clnt_create: RPC: Program not registered

[floki@flokipal ~]$ su -
Password: 
[root@flokipal ~]# showmount -e 192.168.1.35
Export list for 192.168.1.35:
/mnt/ymislegt *
/mnt/tonlist  *
[root@flokipal ~]# service nfs status
rpc.mountd (pid 1033) is running...
nfsd (pid 1030 1029 1028 1027 1026 1025 1024 1023) is running...
rpc.rquotad (pid 1018) is running...
[root@flokipal ~]# service nfs stop
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
[root@flokipal ~]# showmount -e 192.168.1.35
clnt_create: RPC: Program not registered
[root@flokipal ~]#

Note You need to log in before you can comment on or make changes to this bug.