Bug 52828 - dhcpcd hangs on boot when network cable is not presnt
dhcpcd hangs on boot when network cable is not presnt
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: dhcpcd (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 14:33 EDT by marv
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-06 06:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marv 2001-08-29 14:33:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
If I boot up my IBM Thinkpad without a network cable dhcpd hangs forever.
This happened after I ran an up2date on my system. Before the up2date, It
would by pass this and I would be able to use my system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rebooted the system with network cable in. System comes up completely
2.rebooted the system without the network cable and it hung.
3.
	

Additional info:
Comment 1 Olivier Baudron 2002-01-06 06:45:25 EST
I cannot reproduce this on my rawhide linux box (not an IBM Thinkpad). It hangs
for two minutes then the booting process goes on.

12:14:01 baud ifup: Determining IP information for eth0...
[...]
12:16:01 baud dhcpcd[326]: timed out waiting for a valid DHCP server response 
12:16:01 baud ifup:  failed.
12:16:01 baud network: Bringing up interface eth0:  failed
[...]
Comment 2 Elliot Lee 2002-03-08 10:41:46 EST
Solution: plug network cable in, then reboot.

Note You need to log in before you can comment on or make changes to this bug.