Bug 528368 - Duplicate "Provides" entries
Duplicate "Provides" entries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-11 14:18 EDT by Matt McCutchen
Modified: 2009-10-18 20:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-18 20:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt McCutchen 2009-10-11 14:18:38 EDT
Description of problem:
Each of the packages liberation-mono-fonts, liberation-sans-fonts, liberation-serif-fonts contains a duplicate "provide" for its own name-version-release in addition to the one implicitly generated by rpm.

Version-Release number of selected component (if applicable):
liberation-serif-fonts-1.04.93-10.fc11.noarch
liberation-sans-fonts-1.04.93-10.fc11.noarch
liberation-mono-fonts-1.04.93-10.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --provides -a 'liberation-*-fonts' | grep '^liberation'

Actual results:
liberation-serif-fonts = 1.04.93-10.fc11
liberation-serif-fonts = 1.04.93-10.fc11
liberation-sans-fonts = 1.04.93-10.fc11
liberation-sans-fonts = 1.04.93-10.fc11
liberation-mono-fonts = 1.04.93-10.fc11
liberation-mono-fonts = 1.04.93-10.fc11

Expected results:
liberation-serif-fonts = 1.04.93-10.fc11
liberation-sans-fonts = 1.04.93-10.fc11
liberation-mono-fonts = 1.04.93-10.fc11

Additional info:
It looks like this has already been fixed in rawhide in liberation-fonts-1.04.93-11, according to the spec file in CVS:

http://cvs.fedoraproject.org/viewvc/rpms/liberation-fonts/devel/liberation-fonts.spec?r1=1.36&r2=1.37

So feel free to mark this CLOSED RAWHIDE if you don't wish to make the fix for Fedora 11.  I thought I'd ask because the duplicate provides came up when I was doing some checks on my RPM database.

Note You need to log in before you can comment on or make changes to this bug.