This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528404 - Sound regression from F12 Alpha kde after update to rawhide current
Sound regression from F12 Alpha kde after update to rawhide current
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: phonon (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-11 21:27 EDT by Tony White
Modified: 2009-10-14 10:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 10:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tony White 2009-10-11 21:27:49 EDT
Description of problem:

Sound regression. kde 4.

Sound in kde 4 is gone after updating to rawhide from an install of the alpha.
The system sounds don't play, the systemsettings audio output tests produce no sound and there is no sound watching flash videos in Opera web browser.
I also tried a flac file in juk after installing gstreamer-plugins-good. No dice.
Audio was fine before I pulled the updates from Alpha to current rawhide.

Version-Release number of selected component (if applicable):

fedora 11.91

How reproducible:

Every boot there is no sound.

Steps to Reproduce:
1. Install F12 Alpha
2. su -
3. yum check-update && yum upgrade
4. reboot
  
Actual results:
No sound can be played back by any means.

Expected results:
Sound plays back through the speakers and can be heard loudly.

Additional info:

This is a regression but I don't know which component is causing it. pulseaudio???
I've tried rolling back to some of the packages from the alpha release without any useful results.

rpm -Uvh --oldpackage alsa-utils
rpm -Uvh --oldpackage alsa-lib
rpm -Uvh --oldpackage alsa-plugins-pulseaudio

Downloaded the alpha packages from here :
http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/12-Alpha/Fedora/i386/os/Packages/

The sound card is an AC'97 according to lspici -vv :

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)                                     
        Subsystem: ASUSTeK Computer Inc. Device 1743                            
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-                                                   
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-                                                  
        Latency: 0                                                              
        Interrupt: pin B routed to IRQ 11                                       
        Region 0: I/O ports at e000 [size=256]                                  
        Region 1: I/O ports at e100 [size=64]                                   
        Region 2: Memory at 40000400 (32-bit, non-prefetchable) [size=512]      
        Region 3: Memory at 40000600 (32-bit, non-prefetchable) [size=256]      
        Capabilities: [50] Power Management version 2                           
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)                                                                    
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-          
        Kernel driver in use: Intel ICH                                         
        Kernel modules: snd-intel8x0
Comment 1 Tony White 2009-10-12 03:06:26 EDT
I tried playing a wav file in a console using aplay and there was no sound but the output showed as pulseaudio and there was visual feedback.
I did :
yum erase alsa-plugins-pulseaudio
which resulted in :
Loaded plugins: refresh-packagekit             
Setting up Remove Process                      
Resolving Dependencies                         
--> Running transaction check                  
---> Package alsa-plugins-pulseaudio.i686 0:1.0.21-2.fc12 set to be erased
--> Processing Dependency: alsa-plugins-pulseaudio for package: kde-settings-pulseaudio-4.3-10.1.noarch
--> Running transaction check                                                                          
---> Package kde-settings-pulseaudio.noarch 0:4.3-10.1 set to be erased                                
--> Finished Dependency Resolution                                                                     

Dependencies Resolved

=============================================================================================================================
 Package                                Arch                  Version                         Repository                Size 
=============================================================================================================================
Removing:                                                                                                                    
 alsa-plugins-pulseaudio                i686                  1.0.21-2.fc12                   installed                 87 k 
Removing for dependencies:                                                                                                   
 kde-settings-pulseaudio                noarch                4.3-10.1                        installed                 0.0  

Transaction Summary
=============================================================================================================================
Remove        2 Package(s)                                                                                                   
Reinstall     0 Package(s)                                                                                                   
Downgrade     0 Package(s)                                                                                                   

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction       
Warning: RPMDB has been altered since the last yum transaction.
  Erasing        : kde-settings-pulseaudio-4.3-10.1.noarch                                                               1/2 
  Erasing        : alsa-plugins-pulseaudio-1.0.21-2.fc12.i686                                                            2/2 

Removed:
  alsa-plugins-pulseaudio.i686 0:1.0.21-2.fc12                                                                               

Dependency Removed:
  kde-settings-pulseaudio.noarch 0:4.3-10.1                                                                                  

Complete!

I tried the wav file again in the terminal using aplay and it came through the speakers. I opened opera web browser and went to youtube and flash video now has sound.

However, I opened kde's systemsettings tool and none of the sound tests in the multimedia section produced any sound.
So maybe this is a pulseaudio and phonon problem???

I'm happy enough now though. I would like to use pulseaudio though. The sound quality is much better than just going straight through alsa.
Comment 2 Lennart Poettering 2009-10-12 18:28:27 EDT
Sounds like a mixer setup problem. Have you use gnome-volume-control to select the right profile and output port for your device?

Have you played around with "alsamixer -c0" and tried to figure out if some control was not initialized properly for you by default?

Does audio work in GNOME? I don't use KDE personally and do not maintain it. If this problem is KDE-specific this should be reassigning to kde in some way.
Comment 3 Tony White 2009-10-12 19:24:31 EDT
I can't use any gtk apps right now because they all segfault.
I used alsamixer and it displayed the pulseaudio alsa plugin as the master channel at full volume, which lead me to think to uninstall it, which worked.
This problem isn't just in kde, it's from the command line because I used aplay to test the sound and I could hear no sound until I uninstalled alsa-plugins-pulseaudio. So while I can now use aplay in a terminal and flash plugin works in opera, no kde apps like juk play audio (A flac file and I have gstreamer-plugins-good installed.)
The volume levels are all fine, I used alsamixer to check them and when sound is playing in Opera from a flash video I can still use the volume control in the tray (kmix) To change the volume for the pcm and the master channels.

So I think that this is two bugs now after alsa-plugins-pulseaudio.
1. alsa-plugins-pulseaudio no longer works for my card from a console.
2. alsa output no longer works in kde.

Using yum to downgrade alsa-plugins-pulseaudio didn't seem to have the desired effect either because it was one of the first things I tried when I discovered sound was foobar.
Comment 4 Adam Williamson 2009-10-13 17:45:06 EDT
could you try with the Desktop nightly live image - from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/ - and see what happens with that? That will be running GNOME not KDE, which will let us know if this problem is KDE-specific. (No, just the fact that it happens with apps that aren't 'KDE apps' doesn't prove that; you're still running them within KDE).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Tony White 2009-10-13 18:52:10 EDT
Thanks Adam, will try. I'm certain this is a pulseaudio problem with the card on this machine or regression if you like, I just re-installed the alpha and carefully pulled the updates, the sound works up until the pulseaudio updates come through and that does not include alsa-plugins-pulseaudio or kde-settings-pulseaudio.
We'll see anyway with this new coaster I'll be burning. ;)
Comment 6 Tony White 2009-10-13 22:43:57 EDT
Yep that works. A flac file in rhythmbox and a wav file using aplay in a terminal. Both fine.
Must be a kde thing then?
Comment 7 Adam Williamson 2009-10-14 01:30:53 EDT
It would appear so (if you have a bit more bandwidth to kill you could always check the KDE nightly live build to see how that one behaves).

taking a guess at Phonon as an initial assignee for this.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Kevin Kofler 2009-10-14 01:42:18 EDT
Can you try the current KDE nightly? http://alt.fedoraproject.org/pub/alt/nightly-composes/kde/

We're using phonon-backend-xine by default now (again, as in previous releases, we tried using phonon-backend-gstreamer as default in F12 Alpha).
Comment 9 Tony White 2009-10-14 02:01:57 EDT
@Adam : Yep I'll try that too :) ...no more coasters though, I can't help feeling responsible for that plastic island in the pacific or just adding to the land fill, unetbootin for this one I think.

@Kevin : Thank you for the link. Looks like an overburn at 701 MB but I won't be burning it. Will grab whilst hot.
You know; using the kde alpha, juk was actually ok using gstreamer (gstreamer-plugins-good I think) To play flac files. It was just using the "Not so good" Codecs it fell down. phonon-xine is probably the right choice, it's just kind of weird that gstreamer + phonon still don't mix right.
Comment 10 Kevin Kofler 2009-10-14 02:45:38 EDT
701 MB are definitely going to fit on the common 700 MB CDs. But we're looking at whether we can shave off a few MB to make common burning programs (including K3b) not complain.
Comment 11 Tony White 2009-10-14 05:04:28 EDT
That worked too. Maybe a difference in config between updates? That kde snapshot played both wav using aplay in a konsole and a flac file using juk after pulling gstreamer-plugins-good.
I used alsamixer to check and the output was going straight through the alsa-plugin-pulseaudio as a single volume channel.

Close the bug report; I think (Thanks guys!)

Kevin, I used the copy of k3b that was included with the alpha to burn kde nightly disc to a cdrw and it dealt with it well. It even erased the disc first OK.
I can't really understand at all why that qt4 version of k3b has been shelved. I've used it quite a bit now and it works well here.
Comment 12 Kevin Kofler 2009-10-14 07:35:34 EDT
Don't ask me, I didn't see a reason for reverting K3b either and I fought against it, but I was outvoted. :-/
Comment 13 Rex Dieter 2009-10-14 10:45:25 EDT
closing per comment #11

Note You need to log in before you can comment on or make changes to this bug.