Bug 52857 - gcc crashes when trying to compile libiodbc-3.0.5
gcc crashes when trying to compile libiodbc-3.0.5
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 21:36 EDT by Paulo Lindoso
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-29 21:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Lindoso 2001-08-29 21:36:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When I try to compile libiodbc-3.0.5, it crashes on different points of 
the compilation either with a Segmentation Fault or with an "Error 1" 
message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download libiodbc-3.0.5 from www.iodbc.org
2. tar xzvf libiodbc-3.0.5.tar.gz
3. ./configure
4. make

	

Actual Results:  3 different outputs from 3 different compiles (all from 
scratch) follows:
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c result.c  -fPIC -DPIC -o result.o
mv -f result.o .libs/result.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c result.c -o result.o >/dev/null 2>&1
mv -f .libs/result.lo result.lo
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -
I../include -I../include    -g -O2 -DODBCVER=0x0350 -c odbc3.c
rm -f .libs/odbc3.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c odbc3.c  -fPIC -DPIC -o odbc3.o
odbc3.c: In function `SQLSetStmtAttr':
odbc3.c:1191: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [odbc3.lo] Error 1
make[1]: Leaving directory `/export/progs/libiodbc-3.0.5/iodbc'
make: *** [all-recursive] Error 1
[root@victoria libiodbc-3.0.5]# 


---------------------------------

gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c hdbc.c -o hdbc.o >/dev/null 2>&1
mv -f .libs/hdbc.lo hdbc.lo
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -
I../include -I../include    -g -O2 -DODBCVER=0x0350 -c henv.c
rm -f .libs/henv.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c henv.c  -fPIC -DPIC -o henv.o
mv -f henv.o .libs/henv.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c henv.c -o henv.o >/dev/null 2>&1
mv -f .libs/henv.lo henv.lo
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -
I../include -I../include    -g -O2 -DODBCVER=0x0350 -c herr.c
rm -f .libs/herr.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c herr.c  -fPIC -DPIC -o herr.o
mv -f herr.o .libs/herr.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c herr.c -o herr.o >/dev/null 2>&1
make[1]: *** [herr.lo] Error 1
make[1]: Leaving directory `/export/progs/libiodbc-3.0.5/iodbc'
make: *** [all-recursive] Error 1
[root@victoria libiodbc-3.0.5]# 

-------------------------------------

gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c dlf.c -o dlf.o >/dev/null 2>&1
mv -f .libs/dlf.lo dlf.lo
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -
I../include -I../include    -g -O2 -DODBCVER=0x0350 -c dlproc.c
rm -f .libs/dlproc.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c dlproc.c  -fPIC -DPIC -o dlproc.o
mv -f dlproc.o .libs/dlproc.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c dlproc.c -o dlproc.o >/dev/null 2>&1
mv -f .libs/dlproc.lo dlproc.lo
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -
I../include -I../include    -g -O2 -DODBCVER=0x0350 -c execute.c
rm -f .libs/execute.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -O2 -
DODBCVER=0x0350 -c execute.c  -fPIC -DPIC -o execute.o
execute.c: In function `SQLPutData':
execute.c:452: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [execute.lo] Error 1
make[1]: Leaving directory `/export/progs/libiodbc-3.0.5/iodbc'
make: *** [all-recursive] Error 1
[root@victoria libiodbc-3.0.5]# 

---------------------------------------------------



Expected Results:  Program should compile normally.

Additional info:

I have managed to compile this program on a HP Vectra computer (P3-750Mhz, 
128MB RAM), but have been unable to do so in my computer at home, a AMD K6-
200MHZ, 256MB RAM.  I have applied CPP patch and am using gcc-2.96-85, but 
it still crashes.  In fact, since I upgraded to RH7.1, I haven't been able 
to compile anything in my Linux box.  Binary RPMs work OK, but compilation 
always fails miserably.
Comment 1 Jakub Jelinek 2001-08-30 04:15:09 EDT
gcc stresses CPU and the memory subsystem heavily and in different pattern
than most other commonly used programs.
Nonreproducible random errors like this are in 99.999% cases because of
flakey hardware.

Note You need to log in before you can comment on or make changes to this bug.