Bug 528620 - Some dialogs don't get input when ibus is enabled
Some dialogs don't get input when ibus is enabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 02:01 EDT by niklas.laxstrom+bro@gmail.com
Modified: 2009-11-25 00:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-25 00:36:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description niklas.laxstrom+bro@gmail.com 2009-10-13 02:01:08 EDT
Description of problem:
When ibus is enabled (as in running, not necessarily having any input method active), some dialog accept keyboard input only occasionally, and when putting the focus on some another input, the letters written suddenly appear there.
Some dialogs don't accept input at all, for example the file open dialog of kate. Problem goes away immediately when ibus-daemon is killed or ibus is disabled.


Version-Release number of selected component (if applicable):
All software is latest in F11 with additional kde and kde-testing repositories enabled. I'm using KDE desktop.
Comment 1 Peng Huang 2009-10-13 22:04:08 EDT
Please list all installed ibus packages `rpm -qa ibus\*'.
Comment 2 niklas.laxstrom+bro@gmail.com 2009-10-14 01:56:55 EDT
Here it is:
ibus-m17n-1.2.0.20090617-2.fc11.x86_64
ibus-anthy-1.2.0.20090917-1.fc11.x86_64
ibus-1.2.0.20090927-1.fc11.x86_64
ibus-libs-1.2.0.20090927-1.fc11.x86_64
ibus-rawcode-1.2.0.20090703-1.fc11.x86_64
ibus-gtk-1.2.0.20090927-1.fc11.x86_64
ibus-table-additional-1.2.0.20090912-1.fc11.noarch
ibus-table-1.2.0.20090912-1.fc11.noarch
Comment 3 Peng Huang 2009-10-14 02:14:47 EDT
Please try install ibus-qt
Comment 4 niklas.laxstrom+bro@gmail.com 2009-10-14 05:21:29 EDT
Where should I get it from, because yum says: No package ibus-qt available.
Comment 5 Jens Petersen 2009-11-03 22:25:22 EST
It is in f11 updates now.

https://admin.fedoraproject.org/updates/F11/FEDORA-2009-10286
Comment 6 niklas.laxstrom+bro@gmail.com 2009-11-18 03:36:06 EST
Problems seems to have been disappeared after installing ibus-qt. There is still occassional problems with JOSM, but that may be a different issue altogether.
Comment 7 Peng Huang 2009-11-25 00:36:02 EST
Close it as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.