Bug 52867 - Kernel panic with ext3 module in initrd
Summary: Kernel panic with ext3 module in initrd
Status: CLOSED DUPLICATE of bug 52143
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mount   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-30 08:12 UTC by Andreas Kumpf
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 08:12:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Kumpf 2001-08-30 08:12:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
System hangs on bootup since ext3 module is compiled into ram disk

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create initrd with mkinitrd /boot/initrd-2.4.7-2.img 2.4.7-2
2. Substitute entries in /etc/fstab with ext3
3. Reboot

Actual Results:  System hangs after loading the ext3 modules (ext, jbd) 
with:
pivotroot: pivot_root(/sysroot, /sysroot/initrd) failed: 2
kernel panic: No init found. Try passing init=option to kernel.
	

Expected Results:  Normal startup with / journalled.

Additional info:

- I don't think there's a problem with initrd, since Ram Disk is found and 
the appropriated modules are loaded.
- I have to mount my installation in rescue mode to delete /boot/initrd-
2.4.7-2.img from lilo configuration. After this everything works fine.
- Other filesystems in my system are mounted with journalled function.

Comment 1 Bernhard Rosenkraenzer 2001-08-30 09:27:20 UTC

*** This bug has been marked as a duplicate of 52143 ***


Note You need to log in before you can comment on or make changes to this bug.