This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528808 - Suyin CORP webcam incorporated into a laptop stop work after hibernate
Suyin CORP webcam incorporated into a laptop stop work after hibernate
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 15:54 EDT by Maximiliano Castanon
Modified: 2009-12-26 00:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-26 00:50:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg information (120.15 KB, application/octet-stream)
2009-11-20 22:33 EST, Maximiliano Castanon
no flags Details
lshal information (118.35 KB, application/octet-stream)
2009-11-20 22:34 EST, Maximiliano Castanon
no flags Details
/proc/bus/input/devices information (2.65 KB, application/octet-stream)
2009-11-20 22:37 EST, Maximiliano Castanon
no flags Details
dmidecode information, BIOS (10.10 KB, application/octet-stream)
2009-11-20 22:38 EST, Maximiliano Castanon
no flags Details
lsmod information (2.12 KB, application/octet-stream)
2009-11-20 22:39 EST, Maximiliano Castanon
no flags Details
lspci information verbose (25.80 KB, application/octet-stream)
2009-11-20 22:41 EST, Maximiliano Castanon
no flags Details
most recent dmesg log (73.57 KB, application/octet-stream)
2009-11-20 22:53 EST, Maximiliano Castanon
no flags Details
lsusb -vv only EHCI 2.0 working (10.73 KB, application/octet-stream)
2009-11-20 23:04 EST, Maximiliano Castanon
no flags Details

  None (edit)
Description Maximiliano Castanon 2009-10-13 15:54:34 EDT
Description of problem:
after hibernate Fedora GNU/Linux, the webcam incorporated on my laptop freeze and don't work anymore...

Version-Release number of selected component (if applicable):

[maximi89@gateway ~]$ sudo lsusb -v -d 064e:a103

Bus 002 Device 002: ID 064e:a103 Suyin Corp. 



How reproducible:
suspend to disk, poweron the computer again, and you see a problem starting the webcam from hibernated state.

Steps to Reproduce:
1.hibernate
2.poweron the computer
3.try to use the webcam
  
Actual results:

[drm] Resetting GPU
PM: Marking nosave pages: 000000000009d000 - 0000000000100000
PM: Basic memory bitmaps created
PM: Syncing filesystems ... done.
Freezing user space processes ... (elapsed 0.03 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
PM: Shrinking memory... done (140390 pages freed)
PM: Freed 561560 kbytes in 12.22 seconds (45.95 MB/s)
Suspending console(s) (use no_console_suspend to debug)
btusb_bulk_complete: hci0 urb ee049f80 failed to resubmit (1)
btusb_bulk_complete: hci0 urb ee049500 failed to resubmit (1)
btusb_intr_complete: hci0 urb ee049380 failed to resubmit (1)
sd 0:0:0:0: [sda] Synchronizing SCSI cache
ACPI handle has no context!
ath9k 0000:09:00.0: PCI INT A disabled
tg3 0000:03:00.0: PME# enabled
HDA Intel 0000:01:05.1: PCI INT B disabled
ACPI handle has no context!
HDA Intel 0000:00:14.2: PCI INT A disabled
HDA Intel 0000:00:14.2: power state changed by ACPI to D3
ehci_hcd 0000:00:13.2: PCI INT B disabled
ehci_hcd 0000:00:13.2: PME# disabled
ohci_hcd 0000:00:13.0: PCI INT A disabled
ehci_hcd 0000:00:12.2: PCI INT B disabled
ehci_hcd 0000:00:12.2: PME# disabled
ohci_hcd 0000:00:12.1: PCI INT A disabled
ohci_hcd 0000:00:12.0: PCI INT A disabled
ahci 0000:00:11.0: PCI INT A disabled
ACPI: Preparing to enter system sleep state S4
PM: Saving platform NVS memory
Disabling non-boot CPUs ...
CPU 1 is now offline
SMP alternatives: switching to UP code
CPU0 attaching NULL sched-domain.
CPU1 attaching NULL sched-domain.
CPU0 attaching NULL sched-domain.
CPU1 is down
PM: Creating hibernation image: 
PM: Need to copy 124897 pages
PM: Normal pages needed: 45614 + 1024 + 88, available pages: 181591
x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
PM: Restoring platform NVS memory
Enabling non-boot CPUs ...
SMP alternatives: switching to SMP code
Booting processor 1 APIC 0x1 ip 0x6000
Initializing CPU#1
Calibrating delay using timer specific routine.. 4189.68 BogoMIPS (lpj=2094842)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 512K (64 bytes/line)
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
x86 PAT enabled: cpu 1, old 0x7040600070406, new 0x7010600070106
CPU1: AMD Athlon(tm) X2 Dual-Core QL-64 stepping 01
CPU0 attaching NULL sched-domain.
Switched to high resolution mode on CPU 1
CPU0 attaching sched-domain:
 domain 0: span 0-1 level MC
  groups: 0 1
CPU1 attaching sched-domain:
 domain 0: span 0-1 level MC
  groups: 1 0
CPU1 is up
ACPI: Waking up from system sleep state S4
ACPI Exception (evregion-0422): AE_TIME, Returned by Handler for [EmbeddedControl] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.AMW0.WMCA] (Node f7010ed0), AE_TIME
ahci 0000:00:11.0: restoring config space at offset 0x1 (was 0x2300003, writing 0x2300007)
HDA Intel 0000:00:14.2: restoring config space at offset 0xf (was 0x10a, writing 0xa)
HDA Intel 0000:00:14.2: restoring config space at offset 0x1 (was 0x4100006, writing 0x4100002)
HDA Intel 0000:01:05.1: restoring config space at offset 0x1 (was 0x100007, writing 0x100003)
tg3 0000:03:00.0: restoring config space at offset 0x1 (was 0x100006, writing 0x100406)
ahci 0000:00:11.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ohci_hcd 0000:00:12.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
ohci_hcd 0000:00:12.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
ehci_hcd 0000:00:12.2: PME# disabled
ehci_hcd 0000:00:12.2: PCI INT B -> GSI 17 (level, low) -> IRQ 17
ehci_hcd 0000:00:12.2: PME# disabled
ohci_hcd 0000:00:13.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
ehci_hcd 0000:00:13.2: PME# disabled
ehci_hcd 0000:00:13.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
ehci_hcd 0000:00:13.2: PME# disabled
HDA Intel 0000:00:14.2: restoring config space at offset 0xf (was 0x10a, writing 0xa)
HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
HDA Intel 0000:01:05.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
HDA Intel 0000:01:05.1: setting latency timer to 64
tg3 0000:03:00.0: PME# disabled
ath9k 0000:09:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
ata4: SATA link down (SStatus 0 SControl 300)
ata3: SATA link down (SStatus 0 SControl 300)
uvcvideo: Failed to set UVC commit control : -71 (exp. 26).
uvcvideo 2-5:1.1: resume error -5
sd 0:0:0:0: [sda] Starting disk
ata2: softreset failed (device not ready)
ata2: failed due to HW bug, retry pmp=0
ata1: softreset failed (device not ready)
ata1: failed due to HW bug, retry pmp=0
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: configured for UDMA/133
ata2.00: configured for UDMA/133
uvcvideo: Failed to set UVC commit control : -71 (exp. 26).
uvcvideo 2-5:1.1: resume error -5
PM: Image restored successfully.
Restarting tasks ... done.
PM: Basic memory bitmaps freed
usb 2-6: reset high speed USB device using ehci_hcd and address 5
[drm] Loading RS780 CP Microcode
[drm] Loading RS780 PFP Microcode
[drm] Resetting GPU
wlan0: authenticate with AP 00:11:6b:17:3a:ae
wlan0: authenticated
wlan0: associate with AP 00:11:6b:17:3a:ae
wlan0: RX AssocResp from 00:11:6b:17:3a:ae (capab=0x431 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 255 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 255 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 255 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 255 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 255 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 10 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 4 ret -71
usb 2-5: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 0 len 2 ret -71


Expected results:
to work after from hibernate state


Additional info:


[maximi89@gateway ~]$ sudo lsusb -v -d 064e:a103

Bus 002 Device 002: ID 064e:a103 Suyin Corp. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2 ?
  bDeviceProtocol         1 Interface Association
  bMaxPacketSize0        64
  idVendor           0x064e Suyin Corp.
  idProduct          0xa103 
  bcdDevice            5.00
  iManufacturer           2 
  iProduct                1 
  iSerial                 3 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength          544
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              500mA
    Interface Association:
      bLength                 8
      bDescriptorType        11
      bFirstInterface         0
      bInterfaceCount         2
      bFunctionClass         14 Video
      bFunctionSubClass       3 Video Interface Collection
      bFunctionProtocol       0 
      iFunction               5 
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      1 Video Control
      bInterfaceProtocol      0 
      iInterface              5 
      VideoControl Interface Descriptor:
        bLength                13
        bDescriptorType        36
        bDescriptorSubtype      1 (HEADER)
        bcdUVC               1.00
        wTotalLength          104
        dwClockFrequency       15.000000MHz
        bInCollection           1
        baInterfaceNr( 0)       1
      VideoControl Interface Descriptor:
        bLength                 9
        bDescriptorType        36
        bDescriptorSubtype      3 (OUTPUT_TERMINAL)
        bTerminalID             2
        wTerminalType      0x0101 USB Streaming
        bAssocTerminal          0
        bSourceID               5
        iTerminal               0 
      VideoControl Interface Descriptor:
        bLength                26
        bDescriptorType        36
        bDescriptorSubtype      6 (EXTENSION_UNIT)
        bUnitID                 4
        guidExtensionCode         {7033f028-1163-2e4a-ba2c-6890eb334016}
        bNumControl             8
        bNrPins                 1
        baSourceID( 0)          3
        bControlSize            1
        bmControls( 0)       0x0f
        iExtension              0 
      VideoControl Interface Descriptor:
        bLength                26
        bDescriptorType        36
        bDescriptorSubtype      6 (EXTENSION_UNIT)
        bUnitID                 5
        guidExtensionCode         {3fae1228-d7bc-114e-a357-6f1edef7d61d}
        bNumControl             8
        bNrPins                 1
        baSourceID( 0)          4
        bControlSize            1
        bmControls( 0)       0xff
        iExtension              0 
      VideoControl Interface Descriptor:
        bLength                18
        bDescriptorType        36
        bDescriptorSubtype      2 (INPUT_TERMINAL)
        bTerminalID             1
        wTerminalType      0x0201 Camera Sensor
        bAssocTerminal          0
        iTerminal               0 
        wObjectiveFocalLengthMin      0
        wObjectiveFocalLengthMax      0
        wOcularFocalLength            0
        bControlSize                  3
        bmControls           0x00000000
      VideoControl Interface Descriptor:
        bLength                12
        bDescriptorType        36
        bDescriptorSubtype      5 (PROCESSING_UNIT)
      Warning: Descriptor too short
        bUnitID                 3
        bSourceID               1
        wMaxMultiplier          0
        bControlSize            3
        bmControls     0x000025bf
          Brightness
          Contrast
          Hue
          Saturation
          Sharpness
          Gamma
          White Balance Component
          Backlight Compensation
          Power Line Frequency
          White Balance Component, Auto
        iProcessing             0 
        bmVideoStandards     0x 0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0010  1x 16 bytes
        bInterval               6
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           0
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      VideoStreaming Interface Descriptor:
        bLength                            14
        bDescriptorType                    36
        bDescriptorSubtype                  1 (INPUT_HEADER)
        bNumFormats                        1
        wTotalLength                      297
        bEndPointAddress                  129
        bmInfo                              0
        bTerminalLink                       2
        bStillCaptureMethod                 0
        bTriggerSupport                     1
        bTriggerUsage                       1
        bControlSize                        1
        bmaControls( 0)                    27
      VideoStreaming Interface Descriptor:
        bLength                            27
        bDescriptorType                    36
        bDescriptorSubtype                  4 (FORMAT_UNCOMPRESSED)
        bFormatIndex                        1
        bNumFrameDescriptors                5
        guidFormat                            {59555932-0000-1000-8000-00aa00389b71}
        bBitsPerPixel                      16
        bDefaultFrameIndex                  1
        bAspectRatioX                       0
        bAspectRatioY                       0
        bmInterlaceFlags                 0x00
          Interlaced stream or variable: No
          Fields per frame: 1 fields
          Field 1 first: No
          Field pattern: Field 1 only
          bCopyProtect                      0
      VideoStreaming Interface Descriptor:
        bLength                            50
        bDescriptorType                    36
        bDescriptorSubtype                  5 (FRAME_UNCOMPRESSED)
        bFrameIndex                         1
        bmCapabilities                   0x00
          Still image unsupported
        wWidth                            640
        wHeight                           480
        dwMinBitRate                  3072000
        dwMaxBitRate                 18432000
        dwMaxVideoFrameBufferSize      614400
        dwDefaultFrameInterval         333333
        bFrameIntervalType                  6
        dwFrameInterval( 0)            333333
        dwFrameInterval( 1)            400000
        dwFrameInterval( 2)            500000
        dwFrameInterval( 3)            666666
        dwFrameInterval( 4)           1000000
        dwFrameInterval( 5)           2000000
      VideoStreaming Interface Descriptor:
        bLength                            50
        bDescriptorType                    36
        bDescriptorSubtype                  5 (FRAME_UNCOMPRESSED)
        bFrameIndex                         2
        bmCapabilities                   0x00
          Still image unsupported
        wWidth                            352
        wHeight                           288
        dwMinBitRate                  1013760
        dwMaxBitRate                  6082560
        dwMaxVideoFrameBufferSize      202752
        dwDefaultFrameInterval         333333
        bFrameIntervalType                  6
        dwFrameInterval( 0)            333333
        dwFrameInterval( 1)            400000
        dwFrameInterval( 2)            500000
        dwFrameInterval( 3)            666666
        dwFrameInterval( 4)           1000000
        dwFrameInterval( 5)           2000000
      VideoStreaming Interface Descriptor:
        bLength                            50
        bDescriptorType                    36
        bDescriptorSubtype                  5 (FRAME_UNCOMPRESSED)
        bFrameIndex                         3
        bmCapabilities                   0x00
          Still image unsupported
        wWidth                            320
        wHeight                           240
        dwMinBitRate                   768000
        dwMaxBitRate                  4608000
        dwMaxVideoFrameBufferSize      153600
        dwDefaultFrameInterval         333333
        bFrameIntervalType                  6
        dwFrameInterval( 0)            333333
        dwFrameInterval( 1)            400000
        dwFrameInterval( 2)            500000
        dwFrameInterval( 3)            666666
        dwFrameInterval( 4)           1000000
        dwFrameInterval( 5)           2000000
      VideoStreaming Interface Descriptor:
        bLength                            50
        bDescriptorType                    36
        bDescriptorSubtype                  5 (FRAME_UNCOMPRESSED)
        bFrameIndex                         4
        bmCapabilities                   0x00
          Still image unsupported
        wWidth                            176
        wHeight                           144
        dwMinBitRate                   253440
        dwMaxBitRate                  1520640
        dwMaxVideoFrameBufferSize       50688
        dwDefaultFrameInterval         333333
        bFrameIntervalType                  6
        dwFrameInterval( 0)            333333
        dwFrameInterval( 1)            400000
        dwFrameInterval( 2)            500000
        dwFrameInterval( 3)            666666
        dwFrameInterval( 4)           1000000
        dwFrameInterval( 5)           2000000
      VideoStreaming Interface Descriptor:
        bLength                            50
        bDescriptorType                    36
        bDescriptorSubtype                  5 (FRAME_UNCOMPRESSED)
        bFrameIndex                         5
        bmCapabilities                   0x00
          Still image unsupported
        wWidth                            160
        wHeight                           120
        dwMinBitRate                   192000
        dwMaxBitRate                  1152000
        dwMaxVideoFrameBufferSize       38400
        dwDefaultFrameInterval         333333
        bFrameIntervalType                  6
        dwFrameInterval( 0)            333333
        dwFrameInterval( 1)            400000
        dwFrameInterval( 2)            500000
        dwFrameInterval( 3)            666666
        dwFrameInterval( 4)           1000000
        dwFrameInterval( 5)           2000000
      VideoStreaming Interface Descriptor:
        bLength                             6
        bDescriptorType                    36
        bDescriptorSubtype                 13 (COLORFORMAT)
        bColorPrimaries                     1 (BT.709,sRGB)
        bTransferCharacteristics            1 (BT.709)
        bMatrixCoefficients                 4 (SMPTE 170M (BT.601))
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       1
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x0080  1x 128 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       2
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x0100  1x 256 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       3
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x0320  1x 800 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       4
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x0b20  2x 800 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       5
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x1320  3x 800 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       6
      bNumEndpoints           1
      bInterfaceClass        14 Video
      bInterfaceSubClass      2 Video Streaming
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x1400  3x 1024 bytes
        bInterval               1
can't get device qualifier: Protocol error
can't get debug descriptor: Protocol error
cannot read device status, Protocol error (71)

[maximi89@gateway ~]$ uname -a
Linux gateway 2.6.30.8-64.fc11.i686.PAE #1 SMP Fri Sep 25 04:56:58 EDT 2009 i686 athlon i386 GNU/Linux

[maximi89@gateway ~]$ sudo lsusb -t -v -s 002:002
Bus#  5
`-Dev#   1 Vendor 0x1d6b Product 0x0001
  `-Dev#   5 Vendor 0x1131 Product 0x1004
Bus#  4
`-Dev#   1 Vendor 0x1d6b Product 0x0001
Bus#  3
`-Dev#   1 Vendor 0x1d6b Product 0x0001
Bus#  2
`-Dev#   1 Vendor 0x1d6b Product 0x0002
  |-Dev#   2 Vendor 0x064e Product 0xa103
  `-Dev#   5 Vendor 0x0bda Product 0x0159
Bus#  1
`-Dev#   1 Vendor 0x1d6b Product 0x0002
Comment 1 Maximiliano Castanon 2009-10-17 13:14:04 EDT
rrmod uvcvideo
modprobe -v uvcvideo trace=255 quirks=16

dmesg:

uvcvideo: Adding mapping Brightness to control 00000000-0000-0000-0000-000000000101/2.
uvcvideo: Adding mapping Contrast to control 00000000-0000-0000-0000-000000000101/3.
uvcvideo: Adding mapping Hue to control 00000000-0000-0000-0000-000000000101/6.
uvcvideo: Adding mapping Saturation to control 00000000-0000-0000-0000-000000000101/7.
uvcvideo: Adding mapping Sharpness to control 00000000-0000-0000-0000-000000000101/8.
uvcvideo: Adding mapping Gamma to control 00000000-0000-0000-0000-000000000101/9.
uvcvideo: Adding mapping Backlight Compensation to control 00000000-0000-0000-0000-000000000101/1.
uvcvideo: Adding mapping Gain to control 00000000-0000-0000-0000-000000000101/4.
uvcvideo: Adding mapping Power Line Frequency to control 00000000-0000-0000-0000-000000000101/5.
uvcvideo: Adding mapping Hue, Auto to control 00000000-0000-0000-0000-000000000101/16.
uvcvideo: Adding mapping Exposure, Auto to control 00000000-0000-0000-0000-000000000001/2.
uvcvideo: Adding mapping Exposure, Auto Priority to control 00000000-0000-0000-0000-000000000001/3.
uvcvideo: Adding mapping Exposure (Absolute) to control 00000000-0000-0000-0000-000000000001/4.
uvcvideo: Adding mapping White Balance Temperature, Auto to control 00000000-0000-0000-0000-000000000101/11.
uvcvideo: Adding mapping White Balance Temperature to control 00000000-0000-0000-0000-000000000101/10.
uvcvideo: Adding mapping White Balance Component, Auto to control 00000000-0000-0000-0000-000000000101/13.
uvcvideo: Adding mapping White Balance Blue Component to control 00000000-0000-0000-0000-000000000101/12.
uvcvideo: Adding mapping White Balance Red Component to control 00000000-0000-0000-0000-000000000101/12.
uvcvideo: Adding mapping Focus (absolute) to control 00000000-0000-0000-0000-000000000001/6.
uvcvideo: Adding mapping Focus, Auto to control 00000000-0000-0000-0000-000000000001/8.
uvcvideo: Adding mapping Zoom, Absolute to control 00000000-0000-0000-0000-000000000001/11.
uvcvideo: Adding mapping Zoom, Continuous to control 00000000-0000-0000-0000-000000000001/12.
uvcvideo: Adding mapping Privacy to control 00000000-0000-0000-0000-000000000001/17.
uvcvideo: Probing generic UVC device 5
uvcvideo: Found format YUV 4:2:2 (YUYV).
uvcvideo: - 640x480 (30.0 fps)
uvcvideo: - 352x288 (30.0 fps)
uvcvideo: - 320x240 (30.0 fps)
uvcvideo: - 176x144 (30.0 fps)
uvcvideo: - 160x120 (30.0 fps)
uvcvideo: Found a Status endpoint (addr 83).
uvcvideo: Found UVC 1.00 device Video WebCam (064e:a103)
uvcvideo: Forcing device quirks 0x10 by module parameter for testing purpose.
uvcvideo: Please report required quirks to the linux-uvc-devel mailing list.
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/2 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/3 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/6 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/7 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/8 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/9 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/12 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/1 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/5 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/13 to device 5 entity 3
uvcvideo: Scanning UVC chain: OT 2 <- XU 5 <- XU 4 <- PU 3 <- IT 1
uvcvideo: Found a valid video chain (1 -> 2).
uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
uvcvideo: Failed to query (129) UVC probe control : -71 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
Comment 2 Maximiliano Castanon 2009-11-01 22:35:43 EST
[root@gateway luvcview]# gstreamer-properties 
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': No se pudo abrir el dispositivo «/dev/video0» para lectura y escritura. [v4l2_calls.c(496): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src3:
system error: No existe el dispositivo o la dirección]


[root@gateway luvcview]# /usr/local/bin/luvcview 
luvcview 0.2.6

SDL information:
  Video driver: x11
  A window manager is available
Device information:
  Device path:  /dev/video0
ERROR opening V4L interface: No such device or address
Comment 3 Maximiliano Castanon 2009-11-01 22:37:11 EST
wlan0: associate with AP 00:11:6b:17:3a:ae
wlan0: RX ReassocResp from 00:11:6b:17:3a:ae (capab=0x431 status=0 aid=1)
wlan0: associated
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
uvcvideo: Failed to query (135) UVC control 2 (unit 3) : -71 (exp. 2).
usbcore: deregistering interface driver uvcvideo
uvcvideo: Found UVC 1.00 device Video WebCam (064e:a103)
uvcvideo: Forcing device quirks 0x2 by module parameter for testing purpose.
uvcvideo: Please report required quirks to the linux-uvc-devel mailing list.
uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
uvcvideo: Failed to query (129) UVC probe control : -71 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
usbcore: deregistering interface driver uvcvideo
uvcvideo: Adding mapping Brightness to control 00000000-0000-0000-0000-000000000101/2.
uvcvideo: Adding mapping Contrast to control 00000000-0000-0000-0000-000000000101/3.
uvcvideo: Adding mapping Hue to control 00000000-0000-0000-0000-000000000101/6.
uvcvideo: Adding mapping Saturation to control 00000000-0000-0000-0000-000000000101/7.
uvcvideo: Adding mapping Sharpness to control 00000000-0000-0000-0000-000000000101/8.
uvcvideo: Adding mapping Gamma to control 00000000-0000-0000-0000-000000000101/9.
uvcvideo: Adding mapping Backlight Compensation to control 00000000-0000-0000-0000-000000000101/1.
uvcvideo: Adding mapping Gain to control 00000000-0000-0000-0000-000000000101/4.
uvcvideo: Adding mapping Power Line Frequency to control 00000000-0000-0000-0000-000000000101/5.
uvcvideo: Adding mapping Hue, Auto to control 00000000-0000-0000-0000-000000000101/16.
uvcvideo: Adding mapping Exposure, Auto to control 00000000-0000-0000-0000-000000000001/2.
uvcvideo: Adding mapping Exposure, Auto Priority to control 00000000-0000-0000-0000-000000000001/3.
uvcvideo: Adding mapping Exposure (Absolute) to control 00000000-0000-0000-0000-000000000001/4.
uvcvideo: Adding mapping White Balance Temperature, Auto to control 00000000-0000-0000-0000-000000000101/11.
uvcvideo: Adding mapping White Balance Temperature to control 00000000-0000-0000-0000-000000000101/10.
uvcvideo: Adding mapping White Balance Component, Auto to control 00000000-0000-0000-0000-000000000101/13.
uvcvideo: Adding mapping White Balance Blue Component to control 00000000-0000-0000-0000-000000000101/12.
uvcvideo: Adding mapping White Balance Red Component to control 00000000-0000-0000-0000-000000000101/12.
uvcvideo: Adding mapping Focus (absolute) to control 00000000-0000-0000-0000-000000000001/6.
uvcvideo: Adding mapping Focus, Auto to control 00000000-0000-0000-0000-000000000001/8.
uvcvideo: Adding mapping Zoom, Absolute to control 00000000-0000-0000-0000-000000000001/11.
uvcvideo: Adding mapping Zoom, Continuous to control 00000000-0000-0000-0000-000000000001/12.
uvcvideo: Adding mapping Privacy to control 00000000-0000-0000-0000-000000000001/17.
uvcvideo: Probing generic UVC device 5
uvcvideo: Found format YUV 4:2:2 (YUYV).
uvcvideo: - 640x480 (30.0 fps)
uvcvideo: - 352x288 (30.0 fps)
uvcvideo: - 320x240 (30.0 fps)
uvcvideo: - 176x144 (30.0 fps)
uvcvideo: - 160x120 (30.0 fps)
uvcvideo: Found a Status endpoint (addr 83).
uvcvideo: Found UVC 1.00 device Video WebCam (064e:a103)
uvcvideo: Forcing device quirks 0x2 by module parameter for testing purpose.
uvcvideo: Please report required quirks to the linux-uvc-devel mailing list.
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/2 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/3 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/6 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/7 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/8 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/9 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/12 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/1 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/5 to device 5 entity 3
uvcvideo: Added control 00000000-0000-0000-0000-000000000101/13 to device 5 entity 3
uvcvideo: Scanning UVC chain: OT 2 <- XU 5 <- XU 4 <- PU 3 <- IT 1
uvcvideo: Found a valid video chain (1 -> 2).
uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
uvcvideo: Failed to query (129) UVC probe control : -71 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
[root@gateway luvcview]#
Comment 4 Maximiliano Castanon 2009-11-20 22:33:22 EST
Created attachment 372676 [details]
dmesg information
Comment 5 Maximiliano Castanon 2009-11-20 22:34:57 EST
Created attachment 372677 [details]
lshal information
Comment 6 Maximiliano Castanon 2009-11-20 22:37:00 EST
Created attachment 372678 [details]
/proc/bus/input/devices information
Comment 7 Maximiliano Castanon 2009-11-20 22:38:42 EST
Created attachment 372679 [details]
dmidecode information, BIOS
Comment 8 Maximiliano Castanon 2009-11-20 22:39:40 EST
Created attachment 372680 [details]
lsmod information
Comment 9 Maximiliano Castanon 2009-11-20 22:41:08 EST
Created attachment 372682 [details]
lspci information verbose
Comment 10 Maximiliano Castanon 2009-11-20 22:45:24 EST
i believe this could be relationed to ATI Chipset SB700/SB800 EHCI USB, if you read dmesg, you can see the lines saying error at final of the document, that happens when i try to hibernate, if i press the laptop button for deactivate the synaptics touchpad, and maybe the same happens if i press the wireless button... but i have make some tests only when i press the synaptics button, that make fails hibernate and suspend...
Comment 11 Maximiliano Castanon 2009-11-20 22:53:04 EST
Created attachment 372683 [details]
most recent dmesg log
Comment 12 Maximiliano Castanon 2009-11-20 22:59:43 EST
another test i have made is connect my bluetooth device on all ports when Fedora 11 fails, the only port still working is the EHCI 2.0 all other fails, and i test my USB Pendrive, seems to be without energy all others USB ports.
i have made a log of my lsusb -vv when fails with my pendrive connected to it...
Comment 13 Maximiliano Castanon 2009-11-20 23:04:28 EST
Created attachment 372684 [details]
lsusb -vv only EHCI 2.0 working

this log show us EHCI 2.0 is the only USB working of 4 USB i have.
Comment 14 Maximiliano Castanon 2009-12-26 00:50:55 EST
this start to work properly when i hibernate in recently updates of Fedora 11 now i'm using Fedora 12, 2.6.31.9-174

Note You need to log in before you can comment on or make changes to this bug.