Bug 52889 - grubby makes kernel upgrade segfault in %post
Summary: grubby makes kernel upgrade segfault in %post
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-30 15:21 UTC by Trond Eivind Glomsrxd
Modified: 2007-04-18 16:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 15:43:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My grub.conf after upgrade (664 bytes, text/plain)
2001-08-30 15:33 UTC, Trond Eivind Glomsrxd
no flags Details

Description Trond Eivind Glomsrxd 2001-08-30 15:21:25 UTC
Upgrading from 2.4.7-5 to 2.4.7-6 caused grubby to segfault in kernel post.


("Minnesegmentsfeil" == "Segmentation Fault")

[root@halden RPMS]# rpm -Fvh kernel*i686*
Forbereder...               ########################################### [100%] 
  1:kernel           ########################################### [50%]
   2:kernel-smp             ########################################### [100%]
/sbin/new-kernel-pkg: line 23:  7994 Minnesegmentsfeil       /sbin/grubby
--add-kernel=/boot/vmlinuz-$version $INITRD --copy-default --title "Red Hat
Linux ($version)"
/sbin/new-kernel-pkg: line 11:  8009 Minnesegmentsfeil       /sbin/grubby
--remove-kernel=/boot/vmlinuz-$version
[root@halden RPMS]# ls -l kernel*i686*
-rw-r--r--    5 root     root      9706521 aug 29 11:51 kernel-2.4.7-6.i686.rpm
-rw-r--r--    4 root     root     11284061 aug 29 11:54
kernel-debug-2.4.7-6.i686.rpm
-rw-r--r--    5 root     root     10020569 aug 29 11:53
kernel-enterprise-2.4.7-6.i686.rpm
-rw-r--r--    5 root     root     10011504 aug 29 11:52
kernel-smp-2.4.7-6.i686.rpm
[root@halden RPMS]# uname -a
Linux halden 2.4.7-5smp #1 SMP Tue Aug 28 21:05:40 EDT 2001 i686 unknown
[root@halden RPMS]# rpm -q mkinitrd
mkinitrd-3.2.2-1
[root@halden RPMS]#

Comment 1 Erik Troan 2001-08-30 15:30:23 UTC
Teg, could you send me (or attach) your grub.conf?

Comment 2 Trond Eivind Glomsrxd 2001-08-30 15:33:09 UTC
Created attachment 30196 [details]
My grub.conf after upgrade

Comment 3 Erik Troan 2001-08-30 15:43:20 UTC
the grub.conf had a default line which was invalid. grubby is fixed in CVS not
to care.

I don't know how it got this way.

katzj, can you build a new mkinitrd?

Comment 4 Erik Troan 2001-08-30 16:37:44 UTC
the root cause of this was just fixed in CVS.

we need to have a new mkinitrd package built


Note You need to log in before you can comment on or make changes to this bug.