Bug 528915 - [abrt] crash detected in control-center-1:2.28.0-16.fc12
[abrt] crash detected in control-center-1:2.28.0-16.fc12
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:6d50cd423e09efe279ccddb823f...
:
: 529422 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-14 06:27 EDT by Radek Vokal
Modified: 2009-10-22 09:40 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 07:40:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.49 MB, text/plain)
2009-10-14 06:27 EDT, Radek Vokal
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 297111 None None None Never
Launchpad 335029 None None None Never

  None (edit)
Description Radek Vokal 2009-10-14 06:27:41 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Changin icon theme crashed the application

Additional information
======


Attached files
----
backtrace

cmdline
-----
gnome-appearance-properties --show-page=background 


component
-----
control-center


executable
-----
/usr/bin/gnome-appearance-properties


kernel
-----
2.6.31.1-56.fc12.i686


package
-----
control-center-1:2.28.0-16.fc12


reason
-----
Process was terminated by signal 11
Comment 1 Radek Vokal 2009-10-14 06:27:54 EDT
Created attachment 364737 [details]
File: backtrace
Comment 2 Bastien Nocera 2009-10-14 06:44:03 EDT
You should have looked at the backtrace...
Comment 3 Kevin Kofler 2009-10-14 07:40:11 EDT
Using gtk-qt-engine with QGtkStyle is not going to work, you can't have GTK+ and Qt both trying to use each other for drawing! Your backtrace is showing an infinite recursion between gtk-qt-engine and QGtkStyle.

And there is no qt4 package in Fedora anymore, bugs should be filed against qt, not qt4.
Comment 4 Bastien Nocera 2009-10-16 15:14:23 EDT
*** Bug 529422 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Kofler 2009-10-22 09:40:25 EDT
Also seen by our friends over at Ubuntu. They ended up just removing gtk-qt-engine due to this and other issues and due to upstream being basically dead. :-(

Of course it's not possible to use gtk-qt-engine with QGtkStyle, but crashing definitely isn't the nicest way to react. :-(

Note You need to log in before you can comment on or make changes to this bug.