Bug 52905 - gcc seg faults builing JDK hotspot 1.3.1 source
gcc seg faults builing JDK hotspot 1.3.1 source
Status: CLOSED DUPLICATE of bug 39858
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 52958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-30 15:10 EDT by Peter Brown
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 15:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Brown 2001-08-30 15:10:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)

Description of problem:
Got latest JDK 1.3.1 src from Sun. Fresh RH "SeaWolf" installed. Hotspot 
VM in the middle of building and seg faults on: 

../src/os_cpu/linux_i486/vm/bytes_linux_i486.inline.hpp:52 Internal error: 
Segmentation fault.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH 'Seawolf'
2. Download/extract Linux JDK1.3.1 source
3. Build hotspot per instructions from source
	

Actual Results:  Was building then:

../src/os_cpu/linux_i486/vm/bytes_linux_i486.inline.hpp:52 Internal error: 
Segmentation fault.

Expected Results:  a finished build

Additional info:
Comment 1 Jakub Jelinek 2001-08-31 14:18:36 EDT
This smells like #39858 to me.
Can you please check gcc-2.96-86 or above?
Comment 2 Jakub Jelinek 2001-08-31 14:19:48 EDT
*** Bug 52958 has been marked as a duplicate of this bug. ***
Comment 3 Sean Zhong 2001-08-31 15:33:27 EDT
gcc-2.96-85 does not work. 
Where can I find gcc-2.96-86?
Comment 4 Jakub Jelinek 2001-08-31 15:38:08 EDT
You probably cannot find 2.96-86 anywhere (well, I have it in archive),
but you can find e.g. 2.96-96 (ftp://ftp.redhat.com/redhat/linux/beta/roswell/en/os/i386/RedHat/RPMS/)
or maybe even 2.96-97 (if propagated into rawhide).
Comment 5 Jakub Jelinek 2001-09-06 13:43:00 EDT
If this is not fixed by 2.96-86 and above, please reopen. I'm fairly sure
it is fixed.

*** This bug has been marked as a duplicate of 39858 ***

Note You need to log in before you can comment on or make changes to this bug.