This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 529407 - mount -t nfs4 no long works
mount -t nfs4 no long works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
: 529775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-16 12:59 EDT by Peter Staubach
Modified: 2009-11-12 10:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 10:26:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Staubach 2009-10-16 12:59:31 EDT
Description of problem:

Originally, mounting NFSv4 file systems was done via "mount -t nfs4".
Support has been added to support "-o nfsvers=4", which works, but
the original syntax no longer works because an argument, "-o nfsvers=3"
seems to be automatically added.

Both syntaxes should work.
Comment 1 Steve Dickson 2009-10-20 08:23:31 EDT
*** Bug 529775 has been marked as a duplicate of this bug. ***
Comment 2 Andrew McNabb 2009-10-20 11:05:33 EDT
Steve, thanks for figuring out that mine was a duplicate.  By the way, this bug is more serious than it would seem--the error is an unhelpful "mount.nfs4: an incorrect mount option was specified" which is really confusing when no mount options were specified.
Comment 3 Steve Dickson 2009-10-20 12:13:53 EDT
yeah... I have to agree... but now that all the parsing has moved
down to the kernel, that's all the info the mount command gets..
Comment 4 Andrew McNabb 2009-10-21 15:20:30 EDT
It looks like the immediate cause is that /etc/nfsmount.conf now has an nfsvers=3 line.  However, it seems odd that mount.nfs4 is looking at /etc/nfsmount.conf; shouldn't it have its own /etc/nfsmount4.conf or something?
Comment 5 Steve Dickson 2009-10-22 14:45:00 EDT
Yes the nfsvers=3 line is causing the problem.. 

no, we are trying to consolidate nfs4 into nfs... so the 
/etc/nfsmount.conf will cover both..
Comment 6 Andrew McNabb 2009-10-22 15:11:37 EDT
Is this a Fedora-specific consolidation?  Everything I have seen online seems to refer to "mount -t nfs4", not "mount -o nfsvers=4".  If everyone were to move to this, I think it would be a fine idea, but I don't like the idea of Fedora doing things differently than everyone else.
Comment 7 Steve Dickson 2009-10-23 08:07:26 EDT
No, not really.... Over the last few months there has been an effort
to move the default protocol version from version 3 to version 4. 
In that effort, one of the changes that has been made was to add
support for the -o v4/-o nfsvers=4/-o vers=4 mount options. These
options basically hide the fact that nfs4 is truly a separate 
file system. 

So maybe the word 'consolidate' was not quite right... We are just
trying to make a seamless (and hopefully painless) transition to
v4 and a side effect of that transition it will appear -t nfs and
-t nfs4 are becoming one file system, at least from the user 
level perspective.... I hope this helps...
Comment 8 Steve Dickson 2009-10-23 08:13:19 EDT
Fixed in nfs-utils-1.2.0-17.fc12

    http://koji.fedoraproject.org/koji/buildinfo?buildID=137893
Comment 9 Andrew McNabb 2009-10-23 18:47:01 EDT
So what's the "right" thing to do now?  Should I do "-o v4" or should I do "-o nfsvers=4" or should I do "-o vers=4" or should I do "-t nfs4".  I think all of these are great, but I would really appreciate it if there were one official way to do it.

By the way, I tried "-o v4", "-o nfsvers=4", and "-o vers=4" in Fedora 11 and in each case got the error, "mount.nfs: an incorrect mount option was specified".  If one of these is the "right" way to do it, it would really be helpful to backport this to Fedora 11.

Thanks for all of your efforts.  I'm always excited to see things move forward.
Comment 10 Peter Staubach 2009-10-26 08:01:48 EDT
If you want to force NFSv4, then "-o nfsvers=4" should do the trick.

The old way of specifying NFSv4, "-t nfs4" should work, but does not
due to the bug reported here.  As Steve pointed out in Comment #8,
this is fixed in a newer version of nfs-utils.  Perhaps he can be
persuaded to create a new version of nfs-utils for F-11 which does
contain the change.
Comment 11 Steve Dickson 2009-10-26 08:11:10 EDT
> So what's the "right" thing to do now?  Should I do "-o v4" or should I do "-o
> nfsvers=4" or should I do "-o vers=4" or should I do "-t nfs4".  I think all of
> these are great, but I would really appreciate it if there were one official
> way to do it.
There is no official way... I would suggested use the option that best fits
in your current scheme of things... 

>By the way, I tried "-o v4", "-o nfsvers=4", and "-o vers=4" in Fedora 11 and
> in each case got the error, "mount.nfs: an incorrect mount option was
>specified".  If one of these is the "right" way to do it, it would really be
> helpful to backport this to Fedora 11.
Most of the effort to make NFS v4 the default was post F-11 and 
forced more toward F-12 and beyond, but if having these options 
in F-11 would make it easier to transition to F-12, please go a head
and open a BZ on it..
Comment 12 Andrew McNabb 2009-10-26 15:05:46 EDT
Since 'The old way of specifying NFSv4, "-t nfs4" should work', I'll just stick to this, since it's the only thing that's supposed to work everywhere.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.